summaryrefslogtreecommitdiffstats
path: root/patches/gcc-4.3.2/generic/gentoo
diff options
context:
space:
mode:
Diffstat (limited to 'patches/gcc-4.3.2/generic/gentoo')
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/00_all_gcc-4.1-alpha-mieee-default.patch40
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/00_all_gcc-trampolinewarn.patch41
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/03_all_gcc43-java-nomulti.patch44
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/11_all_gcc-netbsd-symbolic.patch18
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/14_all_gcc-sparc64-bsd.patch34
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/18_all_904-flatten-switch-stmt-00.patch80
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/51_all_gcc-3.4-libiberty-pic.patch16
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/53_all_gcc4-superh-default-multilib.patch29
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/54_all_300-libstdc++-pic.patch62
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/61_all_gcc4-ia64-noteGNUstack.patch112
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/61_all_gcc43-pr24170.patch69
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/64_all_gcc43-pr34571.patch41
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/66_all_gcc43-pr25343.patch25
-rw-r--r--patches/gcc-4.3.2/generic/gentoo/74_all_sh-pr24836.patch34
14 files changed, 0 insertions, 645 deletions
diff --git a/patches/gcc-4.3.2/generic/gentoo/00_all_gcc-4.1-alpha-mieee-default.patch b/patches/gcc-4.3.2/generic/gentoo/00_all_gcc-4.1-alpha-mieee-default.patch
deleted file mode 100644
index 0ccb875..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/00_all_gcc-4.1-alpha-mieee-default.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-Set the default behavior on alpha to use -mieee since the large majority of
-time we want this (bad/weird things can happen with packages built without
--mieee).
-
-To satisfy those people who may not want -mieee forced on them all the time,
-we also provide -mno-ieee.
-
-Patch by Mike Frysinger <vapier@gentoo.org>
-
----
- gcc/config/alpha/alpha.h | 2 ++
- gcc/config/alpha/alpha.opt | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
-
-Index: gcc-4.3.1/gcc/config/alpha/alpha.h
-===================================================================
---- gcc-4.3.1.orig/gcc/config/alpha/alpha.h
-+++ gcc-4.3.1/gcc/config/alpha/alpha.h
-@@ -95,6 +95,8 @@ along with GCC; see the file COPYING3.
- while (0)
- #endif
-
-+#define CPP_SPEC "%{!no-ieee:-mieee}"
-+
- #define WORD_SWITCH_TAKES_ARG(STR) \
- (!strcmp (STR, "rpath") || DEFAULT_WORD_SWITCH_TAKES_ARG(STR))
-
-Index: gcc-4.3.1/gcc/config/alpha/alpha.opt
-===================================================================
---- gcc-4.3.1.orig/gcc/config/alpha/alpha.opt
-+++ gcc-4.3.1/gcc/config/alpha/alpha.opt
-@@ -39,7 +39,7 @@ Target RejectNegative Mask(IEEE_CONFORMA
- Request IEEE-conformant math library routines (OSF/1)
-
- mieee
--Target Report RejectNegative Mask(IEEE)
-+Target Report Mask(IEEE)
- Emit IEEE-conformant code, without inexact exceptions
-
- mieee-with-inexact
diff --git a/patches/gcc-4.3.2/generic/gentoo/00_all_gcc-trampolinewarn.patch b/patches/gcc-4.3.2/generic/gentoo/00_all_gcc-trampolinewarn.patch
deleted file mode 100644
index 6b95f70..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/00_all_gcc-trampolinewarn.patch
+++ /dev/null
@@ -1,41 +0,0 @@
- This trivial patch causes gcc to emit a warning whenever
- it generates a trampoline. These are otherwise hard to
- locate. It is rigged to default ON - to have it default
- to OFF remove the text 'Init(1)' from the common.opt
- patch, leaving just 'Common Var(warn_trampolines)'.
- Kevin F. Quinn <kevquinn@gentoo.org> 17 Jan 2006
-
----
- gcc/builtins.c | 3 +++
- gcc/common.opt | 4 ++++
- 2 files changed, 7 insertions(+)
-
-Index: gcc-4.3.1/gcc/common.opt
-===================================================================
---- gcc-4.3.1.orig/gcc/common.opt
-+++ gcc-4.3.1/gcc/common.opt
-@@ -182,6 +182,10 @@ Wsystem-headers
- Common Var(warn_system_headers) Warning
- Do not suppress warnings from system headers
-
-+Wtrampolines
-+Common Var(warn_trampolines) Init(1)
-+Warn whenever a trampoline is generated
-+
- Wuninitialized
- Common Var(warn_uninitialized) Warning
- Warn about uninitialized automatic variables
-Index: gcc-4.3.1/gcc/builtins.c
-===================================================================
---- gcc-4.3.1.orig/gcc/builtins.c
-+++ gcc-4.3.1/gcc/builtins.c
-@@ -5662,6 +5662,9 @@ expand_builtin_init_trampoline (tree exp
- trampolines_created = 1;
- INITIALIZE_TRAMPOLINE (r_tramp, r_func, r_chain);
-
-+ if (warn_trampolines)
-+ warning (OPT_Wtrampolines, "generating trampoline in object (requires executable stack)");
-+
- return const0_rtx;
- }
-
diff --git a/patches/gcc-4.3.2/generic/gentoo/03_all_gcc43-java-nomulti.patch b/patches/gcc-4.3.2/generic/gentoo/03_all_gcc43-java-nomulti.patch
deleted file mode 100644
index f07ead8..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/03_all_gcc43-java-nomulti.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- libjava/configure.ac.jj 2007-12-07 17:55:50.000000000 +0100
-+++ libjava/configure.ac 2007-12-07 18:36:56.000000000 +0100
-@@ -82,6 +82,13 @@ AC_ARG_ENABLE(java-maintainer-mode,
- [allow rebuilding of .class and .h files]))
- AM_CONDITIONAL(JAVA_MAINTAINER_MODE, test "$enable_java_maintainer_mode" = yes)
-
-+AC_ARG_ENABLE(libjava-multilib,
-+ AS_HELP_STRING([--enable-libjava-multilib], [build libjava as multilib]))
-+if test "$enable_libjava_multilib" = no; then
-+ multilib=no
-+ ac_configure_args="$ac_configure_args --disable-multilib"
-+fi
-+
- # It may not be safe to run linking tests in AC_PROG_CC/AC_PROG_CXX.
- GCC_NO_EXECUTABLES
-
---- libjava/configure.jj 2007-12-07 17:55:50.000000000 +0100
-+++ libjava/configure 2007-12-07 18:39:58.000000000 +0100
-@@ -1018,6 +1018,8 @@ Optional Features:
- --enable-gconf-peer compile GConf native peers for util.preferences
- --enable-java-maintainer-mode
- allow rebuilding of .class and .h files
-+ --enable-libjava-multilib
-+ build libjava as multilib
- --disable-dependency-tracking speeds up one-time build
- --enable-dependency-tracking do not reject slow dependency extractors
- --enable-maintainer-mode enable make rules and dependencies not useful
-@@ -1848,6 +1850,16 @@ else
- fi
-
-
-+# Check whether --enable-libjava-multilib was given.
-+if test "${enable_libjava_multilib+set}" = set; then
-+ enableval=$enable_libjava_multilib;
-+fi
-+
-+if test "$enable_libjava_multilib" = no; then
-+ multilib=no
-+ ac_configure_args="$ac_configure_args --disable-multilib"
-+fi
-+
- # It may not be safe to run linking tests in AC_PROG_CC/AC_PROG_CXX.
-
-
diff --git a/patches/gcc-4.3.2/generic/gentoo/11_all_gcc-netbsd-symbolic.patch b/patches/gcc-4.3.2/generic/gentoo/11_all_gcc-netbsd-symbolic.patch
deleted file mode 100644
index f924ff8..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/11_all_gcc-netbsd-symbolic.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-http://bugs.gentoo.org/122698
-
----
- gcc/config/netbsd-elf.h | 1 +
- 1 file changed, 1 insertion(+)
-
-Index: gcc-4.3.1/gcc/config/netbsd-elf.h
-===================================================================
---- gcc-4.3.1.orig/gcc/config/netbsd-elf.h
-+++ gcc-4.3.1/gcc/config/netbsd-elf.h
-@@ -82,6 +82,7 @@ along with GCC; see the file COPYING3.
- #define NETBSD_LINK_SPEC_ELF \
- "%{assert*} %{R*} %{rpath*} \
- %{shared:-shared} \
-+ %{symbolic:-Bsymbolic} \
- %{!shared: \
- -dc -dp \
- %{!nostdlib: \
diff --git a/patches/gcc-4.3.2/generic/gentoo/14_all_gcc-sparc64-bsd.patch b/patches/gcc-4.3.2/generic/gentoo/14_all_gcc-sparc64-bsd.patch
deleted file mode 100644
index e2d0ee1..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/14_all_gcc-sparc64-bsd.patch
+++ /dev/null
@@ -1,34 +0,0 @@
----
- gcc/config/sparc/freebsd.h | 19 ++++++++++++++++---
- 1 file changed, 16 insertions(+), 3 deletions(-)
-
-Index: gcc-4.3.1/gcc/config/sparc/freebsd.h
-===================================================================
---- gcc-4.3.1.orig/gcc/config/sparc/freebsd.h
-+++ gcc-4.3.1/gcc/config/sparc/freebsd.h
-@@ -25,9 +25,22 @@ along with GCC; see the file COPYING3.
- /* FreeBSD needs the platform name (sparc64) defined.
- Emacs needs to know if the arch is 64 or 32-bits. */
-
--#undef CPP_CPU64_DEFAULT_SPEC
--#define CPP_CPU64_DEFAULT_SPEC \
-- "-D__sparc64__ -D__sparc_v9__ -D__sparcv9 -D__arch64__"
-+#undef FBSD_TARGET_CPU_CPP_BUILTINS
-+#define FBSD_TARGET_CPU_CPP_BUILTINS() \
-+ do \
-+ { \
-+ if (TARGET_ARCH64) \
-+ { \
-+ builtin_define ("__sparc64__"); \
-+ builtin_define ("__sparc_v9__"); \
-+ builtin_define ("__sparcv9"); \
-+ } \
-+ else \
-+ builtin_define ("__sparc"); \
-+ builtin_define ("__sparc__"); \
-+ } \
-+ while (0)
-+
-
- #define LINK_SPEC "%(link_arch) \
- %{!mno-relax:%{!r:-relax}} \
diff --git a/patches/gcc-4.3.2/generic/gentoo/18_all_904-flatten-switch-stmt-00.patch b/patches/gcc-4.3.2/generic/gentoo/18_all_904-flatten-switch-stmt-00.patch
deleted file mode 100644
index ce785d9..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/18_all_904-flatten-switch-stmt-00.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-http://gcc.gnu.org/ml/gcc-patches/2007-04/msg00927.html
-
-Hi,
-
-The attached patch makes sure that we create smaller object code for
-simple switch statements. We just make sure to flatten the switch
-statement into an if-else chain, basically.
-
-This fixes a size-regression as compared to gcc-3.4, as can be seen
-below.
-
-2007-04-15 Bernhard Fischer <..>
-
- * stmt.c (expand_case): Do not create a complex binary tree when
- optimizing for size but rather use the simple ordered list.
- (emit_case_nodes): do not emit jumps to the default_label when
- optimizing for size.
-
-Not regtested so far.
-Comments?
-
-Attached is the test switch.c mentioned below.
-
-$ for i in 2.95 3.3 3.4 4.0 4.1 4.2.orig-HEAD 4.3.orig-HEAD 4.3-HEAD;do
-gcc-$i -DCHAIN -Os -o switch-CHAIN-$i.o -c switch.c ;done
-$ for i in 2.95 3.3 3.4 4.0 4.1 4.2.orig-HEAD 4.3.orig-HEAD 4.3-HEAD;do
-gcc-$i -UCHAIN -Os -o switch-$i.o -c switch.c ;done
-
-$ size switch-*.o
- text data bss dec hex filename
- 169 0 0 169 a9 switch-2.95.o
- 115 0 0 115 73 switch-3.3.o
- 103 0 0 103 67 switch-3.4.o
- 124 0 0 124 7c switch-4.0.o
- 124 0 0 124 7c switch-4.1.o
- 124 0 0 124 7c switch-4.2.orig-HEAD.o
- 95 0 0 95 5f switch-4.3-HEAD.o
- 124 0 0 124 7c switch-4.3.orig-HEAD.o
- 166 0 0 166 a6 switch-CHAIN-2.95.o
- 111 0 0 111 6f switch-CHAIN-3.3.o
- 95 0 0 95 5f switch-CHAIN-3.4.o
- 95 0 0 95 5f switch-CHAIN-4.0.o
- 95 0 0 95 5f switch-CHAIN-4.1.o
- 95 0 0 95 5f switch-CHAIN-4.2.orig-HEAD.o
- 95 0 0 95 5f switch-CHAIN-4.3-HEAD.o
- 95 0 0 95 5f switch-CHAIN-4.3.orig-HEAD.o
-
-
-Content-Type: text/x-diff; charset=us-ascii
-Content-Disposition: attachment; filename="gcc-4.3.gcc-flatten-switch-stmt.00.diff"
-
----
- gcc/stmt.c | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-Index: gcc-4.3.1/gcc/stmt.c
-===================================================================
---- gcc-4.3.1.orig/gcc/stmt.c
-+++ gcc-4.3.1/gcc/stmt.c
-@@ -2509,7 +2509,11 @@ expand_case (tree exp)
- use_cost_table
- = (TREE_CODE (orig_type) != ENUMERAL_TYPE
- && estimate_case_costs (case_list));
-- balance_case_nodes (&case_list, NULL);
-+ /* When optimizing for size, we want a straight list to avoid
-+ jumps as much as possible. This basically creates an if-else
-+ chain. */
-+ if (!optimize_size)
-+ balance_case_nodes (&case_list, NULL);
- emit_case_nodes (index, case_list, default_label, index_type);
- emit_jump (default_label);
- }
-@@ -3067,6 +3071,7 @@ emit_case_nodes (rtx index, case_node_pt
- {
- if (!node_has_low_bound (node, index_type))
- {
-+ if (!optimize_size) /* don't jl to the .default_label. */
- emit_cmp_and_jump_insns (index,
- convert_modes
- (mode, imode,
diff --git a/patches/gcc-4.3.2/generic/gentoo/51_all_gcc-3.4-libiberty-pic.patch b/patches/gcc-4.3.2/generic/gentoo/51_all_gcc-3.4-libiberty-pic.patch
deleted file mode 100644
index c690322..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/51_all_gcc-3.4-libiberty-pic.patch
+++ /dev/null
@@ -1,16 +0,0 @@
----
- libiberty/Makefile.in | 1 +
- 1 file changed, 1 insertion(+)
-
-Index: gcc-4.3.1/libiberty/Makefile.in
-===================================================================
---- gcc-4.3.1.orig/libiberty/Makefile.in
-+++ gcc-4.3.1/libiberty/Makefile.in
-@@ -225,6 +225,7 @@ $(TARGETLIB): $(REQUIRED_OFILES) $(EXTRA
- $(AR) $(AR_FLAGS) $(TARGETLIB) \
- $(REQUIRED_OFILES) $(EXTRA_OFILES) $(LIBOBJS); \
- $(RANLIB) $(TARGETLIB); \
-+ cp $(TARGETLIB) ../ ; \
- cd ..; \
- else true; fi
-
diff --git a/patches/gcc-4.3.2/generic/gentoo/53_all_gcc4-superh-default-multilib.patch b/patches/gcc-4.3.2/generic/gentoo/53_all_gcc4-superh-default-multilib.patch
deleted file mode 100644
index 8fc0743..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/53_all_gcc4-superh-default-multilib.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-The gcc-3.x toolchains would contain all the targets by default. With gcc-4,
-you have to actually list out the multilibs you want or you will end up with
-just one when using targets like 'sh4-linux-gnu'.
-
-The resulting toolchain can't even build a kernel as the kernel needs to build
-with the nofpu flag to be sure that no fpu ops are generated.
-
-Here we restore the gcc-3.x behavior; the additional overhead of building all
-of these multilibs by default is negligible.
-
-http://bugs.gentoo.org/140205
-
----
- gcc/config.gcc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-Index: gcc-4.3.1/gcc/config.gcc
-===================================================================
---- gcc-4.3.1.orig/gcc/config.gcc
-+++ gcc-4.3.1/gcc/config.gcc
-@@ -2281,7 +2281,7 @@ sh-*-symbianelf* | sh[12346l]*-*-symbian
- if test x${sh_multilibs} = x ; then
- case ${target} in
- sh64-superh-linux* | \
-- sh[1234]*) sh_multilibs=${sh_cpu_target} ;;
-+ sh[1234]*) sh_multilibs=`cd ${srcdir}/config/sh ; echo t-mlib-sh[1-4]* | sed 's:t-mlib-sh:,m:g;s: ::g'` ;;
- sh64* | sh5*) sh_multilibs=m5-32media,m5-32media-nofpu,m5-compact,m5-compact-nofpu,m5-64media,m5-64media-nofpu ;;
- sh-superh-*) sh_multilibs=m4,m4-single,m4-single-only,m4-nofpu ;;
- sh*-*-linux*) sh_multilibs=m1,m3e,m4 ;;
diff --git a/patches/gcc-4.3.2/generic/gentoo/54_all_300-libstdc++-pic.patch b/patches/gcc-4.3.2/generic/gentoo/54_all_300-libstdc++-pic.patch
deleted file mode 100644
index 3cc3c54..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/54_all_300-libstdc++-pic.patch
+++ /dev/null
@@ -1,62 +0,0 @@
-install libstdc++_pic.a if we have pic objs
-
----
- libstdc++-v3/src/Makefile.am | 7 +++++++
- libstdc++-v3/src/Makefile.in | 12 ++++++++++--
- 2 files changed, 17 insertions(+), 2 deletions(-)
-
-Index: gcc-4.3.1/libstdc++-v3/src/Makefile.am
-===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/src/Makefile.am
-+++ gcc-4.3.1/libstdc++-v3/src/Makefile.am
-@@ -289,6 +289,13 @@ CXXLINK = $(LIBTOOL) --tag CXX --mode=li
- $(OPT_LDFLAGS) $(SECTION_LDFLAGS) $(AM_CXXFLAGS) $(LTLDFLAGS) -o $@
-
-
-+install-exec-local:
-+ pic_objs=`sed -n "s:'::g;s:^pic_object=::p" *.lo | grep -v '^none$$'`; \
-+ if [ x"$$pic_objs" != x ]; then \
-+ $(AR) cru libstdc++_pic.a $$pic_objs $(top_builddir)/libsupc++/*.o || exit 1; \
-+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir) || exit 1; \
-+ fi
-+
- # Added bits to build debug library.
- if GLIBCXX_BUILD_DEBUG
- all-local: build_debug
-Index: gcc-4.3.1/libstdc++-v3/src/Makefile.in
-===================================================================
---- gcc-4.3.1.orig/libstdc++-v3/src/Makefile.in
-+++ gcc-4.3.1/libstdc++-v3/src/Makefile.in
-@@ -693,7 +693,7 @@ info-am:
-
- install-data-am: install-data-local
-
--install-exec-am: install-toolexeclibLTLIBRARIES
-+install-exec-am: install-toolexeclibLTLIBRARIES install-exec-local
-
- install-info: install-info-am
-
-@@ -732,7 +732,7 @@ uninstall-am: uninstall-info-am uninstal
- maintainer-clean-generic mostlyclean mostlyclean-compile \
- mostlyclean-generic mostlyclean-libtool pdf pdf-am ps ps-am \
- tags uninstall uninstall-am uninstall-info-am \
-- uninstall-toolexeclibLTLIBRARIES
-+ uninstall-toolexeclibLTLIBRARIES install-exec-local
-
-
- # Symbol versioning for shared libraries.
-@@ -858,6 +858,14 @@ build_debug: stamp-debug
- install_debug:
- (cd ${debugdir} && $(MAKE) \
- toolexeclibdir=$(glibcxx_toolexeclibdir)/debug install)
-+
-+install-exec-local:
-+ pic_objs=`sed -n "s:'::g;s:^pic_object=::p" *.lo | grep -v '^none$$'`; \
-+ if [ x"$$pic_objs" != x ]; then \
-+ $(AR) cru libstdc++_pic.a $$pic_objs $(top_builddir)/libsupc++/*.o || exit 1; \
-+ $(INSTALL_DATA) libstdc++_pic.a $(DESTDIR)$(toolexeclibdir) || exit 1; \
-+ fi
-+
- # Tell versions [3.59,3.63) of GNU make to not export all variables.
- # Otherwise a system limit (for SysV at least) may be exceeded.
- .NOEXPORT:
diff --git a/patches/gcc-4.3.2/generic/gentoo/61_all_gcc4-ia64-noteGNUstack.patch b/patches/gcc-4.3.2/generic/gentoo/61_all_gcc4-ia64-noteGNUstack.patch
deleted file mode 100644
index e03325d..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/61_all_gcc4-ia64-noteGNUstack.patch
+++ /dev/null
@@ -1,112 +0,0 @@
-2004-09-20 Jakub Jelinek <jakub@redhat.com>
-
- * config/rs6000/ppc-asm.h: Add .note.GNU-stack section also
- on ppc64-linux.
-
- * config/ia64/lib1funcs.asm: Add .note.GNU-stack section on
- ia64-linux.
- * config/ia64/crtbegin.asm: Likewise.
- * config/ia64/crtend.asm: Likewise.
- * config/ia64/crti.asm: Likewise.
- * config/ia64/crtn.asm: Likewise.
-
-2004-05-14 Jakub Jelinek <jakub@redhat.com>
-
- * config/ia64/linux.h (TARGET_ASM_FILE_END): Define.
-
----
- gcc/config/ia64/crtbegin.asm | 4 ++++
- gcc/config/ia64/crtend.asm | 4 ++++
- gcc/config/ia64/crti.asm | 4 ++++
- gcc/config/ia64/crtn.asm | 4 ++++
- gcc/config/ia64/lib1funcs.asm | 4 ++++
- gcc/config/ia64/linux.h | 2 ++
- gcc/config/rs6000/ppc-asm.h | 2 +-
- 7 files changed, 23 insertions(+), 1 deletion(-)
-
-Index: gcc-4.3.1/gcc/config/ia64/crtbegin.asm
-===================================================================
---- gcc-4.3.1.orig/gcc/config/ia64/crtbegin.asm
-+++ gcc-4.3.1/gcc/config/ia64/crtbegin.asm
-@@ -255,3 +255,7 @@ __do_jv_register_classes:
- .weak __cxa_finalize
- #endif
- .weak _Jv_RegisterClasses
-+
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-Index: gcc-4.3.1/gcc/config/ia64/crtend.asm
-===================================================================
---- gcc-4.3.1.orig/gcc/config/ia64/crtend.asm
-+++ gcc-4.3.1/gcc/config/ia64/crtend.asm
-@@ -122,3 +122,7 @@ __do_global_ctors_aux:
-
- br.ret.sptk.many rp
- .endp __do_global_ctors_aux
-+
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-Index: gcc-4.3.1/gcc/config/ia64/crti.asm
-===================================================================
---- gcc-4.3.1.orig/gcc/config/ia64/crti.asm
-+++ gcc-4.3.1/gcc/config/ia64/crti.asm
-@@ -64,3 +64,7 @@ _fini:
- .body
-
- # end of crti.asm
-+
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-Index: gcc-4.3.1/gcc/config/ia64/crtn.asm
-===================================================================
---- gcc-4.3.1.orig/gcc/config/ia64/crtn.asm
-+++ gcc-4.3.1/gcc/config/ia64/crtn.asm
-@@ -54,3 +54,7 @@
- br.ret.sptk.many b0
-
- # end of crtn.asm
-+
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-Index: gcc-4.3.1/gcc/config/ia64/lib1funcs.asm
-===================================================================
---- gcc-4.3.1.orig/gcc/config/ia64/lib1funcs.asm
-+++ gcc-4.3.1/gcc/config/ia64/lib1funcs.asm
-@@ -792,3 +792,7 @@ __floattitf:
- }
- .endp __floattitf
- #endif
-+
-+#ifdef __linux__
-+.section .note.GNU-stack; .previous
-+#endif
-Index: gcc-4.3.1/gcc/config/ia64/linux.h
-===================================================================
---- gcc-4.3.1.orig/gcc/config/ia64/linux.h
-+++ gcc-4.3.1/gcc/config/ia64/linux.h
-@@ -5,6 +5,8 @@
-
- #define TARGET_VERSION fprintf (stderr, " (IA-64) Linux");
-
-+#define TARGET_ASM_FILE_END file_end_indicate_exec_stack
-+
- /* This is for -profile to use -lc_p instead of -lc. */
- #undef CC1_SPEC
- #define CC1_SPEC "%{profile:-p} %{G*}"
-Index: gcc-4.3.1/gcc/config/rs6000/ppc-asm.h
-===================================================================
---- gcc-4.3.1.orig/gcc/config/rs6000/ppc-asm.h
-+++ gcc-4.3.1/gcc/config/rs6000/ppc-asm.h
-@@ -158,7 +158,7 @@ GLUE(.L,name): \
- .size FUNC_NAME(name),GLUE(.L,name)-FUNC_NAME(name)
- #endif
-
--#if defined __linux__ && !defined __powerpc64__
-+#if defined __linux__
- .section .note.GNU-stack
- .previous
- #endif
diff --git a/patches/gcc-4.3.2/generic/gentoo/61_all_gcc43-pr24170.patch b/patches/gcc-4.3.2/generic/gentoo/61_all_gcc43-pr24170.patch
deleted file mode 100644
index c9c46f0..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/61_all_gcc43-pr24170.patch
+++ /dev/null
@@ -1,69 +0,0 @@
-http://gcc.gnu.org/PR24170
-
-2008-02-20 Tom Tromey <tromey@redhat.com>
-
- PR libgcj/24170:
- * java/io/natFilePosix.cc (File::performList): Don't use
- readdir_r.
- * configure, include/config.h.in: Rebuilt.
- * configure.ac: Don't check for readdir_r.
-
----
- libjava/configure.ac | 2 +-
- libjava/include/config.h.in | 3 ---
- libjava/java/io/natFilePosix.cc | 8 +-------
- 3 files changed, 2 insertions(+), 11 deletions(-)
-
-Index: gcc-4.3.1/libjava/configure.ac
-===================================================================
---- gcc-4.3.1.orig/libjava/configure.ac
-+++ gcc-4.3.1/libjava/configure.ac
-@@ -1023,7 +1023,7 @@ if test "x${with_newlib}" = "xyes"; then
- PLATFORMNET=NoNet
- else
- AC_CHECK_FUNCS([strerror_r select fstat open fsync sleep opendir \
-- localtime_r readdir_r getpwuid_r getcwd \
-+ localtime_r getpwuid_r getcwd \
- access stat lstat mkdir rename rmdir unlink utime chmod readlink \
- nl_langinfo setlocale \
- inet_pton uname inet_ntoa \
-Index: gcc-4.3.1/libjava/include/config.h.in
-===================================================================
---- gcc-4.3.1.orig/libjava/include/config.h.in
-+++ gcc-4.3.1/libjava/include/config.h.in
-@@ -214,9 +214,6 @@
- /* Define to 1 if you have the <pwd.h> header file. */
- #undef HAVE_PWD_H
-
--/* Define to 1 if you have the `readdir_r' function. */
--#undef HAVE_READDIR_R
--
- /* Define to 1 if you have the `readlink' function. */
- #undef HAVE_READLINK
-
-Index: gcc-4.3.1/libjava/java/io/natFilePosix.cc
-===================================================================
---- gcc-4.3.1.orig/libjava/java/io/natFilePosix.cc
-+++ gcc-4.3.1/libjava/java/io/natFilePosix.cc
-@@ -1,6 +1,6 @@
- // natFile.cc - Native part of File class for POSIX.
-
--/* Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2006
-+/* Copyright (C) 1998, 1999, 2000, 2001, 2002, 2003, 2006, 2008
- Free Software Foundation
-
- This file is part of libgcj.
-@@ -292,13 +292,7 @@ java::io::File::performList (java::io::F
-
- java::util::ArrayList *list = new java::util::ArrayList ();
- struct dirent *d;
--#if defined(HAVE_READDIR_R) && defined(_POSIX_PTHREAD_SEMANTICS)
-- int name_max = pathconf (buf, _PC_NAME_MAX);
-- char dbuf[sizeof (struct dirent) + name_max + 1];
-- while (readdir_r (dir, (struct dirent *) dbuf, &d) == 0 && d != NULL)
--#else /* HAVE_READDIR_R */
- while ((d = readdir (dir)) != NULL)
--#endif /* HAVE_READDIR_R */
- {
- // Omit "." and "..".
- if (d->d_name[0] == '.'
diff --git a/patches/gcc-4.3.2/generic/gentoo/64_all_gcc43-pr34571.patch b/patches/gcc-4.3.2/generic/gentoo/64_all_gcc43-pr34571.patch
deleted file mode 100644
index 5b3a85a..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/64_all_gcc43-pr34571.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-http://gcc.gnu.org/PR34571
-
-2007-12-26 Rask Ingemann Lambertsen <rask@sygehus.dk>
-
- PR target/34571
- * config/alpha/alpha.c (alpha_cannot_force_const_mem): Use
- symbolic_operand.
- * varasm.c (output_constant_pool_1): Fix typo.
-
----
- gcc/config/alpha/alpha.c | 3 +--
- gcc/varasm.c | 2 +-
- 2 files changed, 2 insertions(+), 3 deletions(-)
-
-Index: gcc-4.3.1/gcc/config/alpha/alpha.c
-===================================================================
---- gcc-4.3.1.orig/gcc/config/alpha/alpha.c
-+++ gcc-4.3.1/gcc/config/alpha/alpha.c
-@@ -1113,8 +1113,7 @@ alpha_legitimize_address (rtx x, rtx scr
- static bool
- alpha_cannot_force_const_mem (rtx x)
- {
-- enum rtx_code code = GET_CODE (x);
-- return code == SYMBOL_REF || code == LABEL_REF || code == CONST;
-+ return symbolic_operand (x, GET_MODE (x));
- }
-
- /* We do not allow indirect calls to be optimized into sibling calls, nor
-Index: gcc-4.3.1/gcc/varasm.c
-===================================================================
---- gcc-4.3.1.orig/gcc/varasm.c
-+++ gcc-4.3.1/gcc/varasm.c
-@@ -3710,7 +3710,7 @@ output_constant_pool_1 (struct constant_
- /* FALLTHRU */
-
- case LABEL_REF:
-- tmp = XEXP (x, 0);
-+ tmp = XEXP (tmp, 0);
- gcc_assert (!INSN_DELETED_P (tmp));
- gcc_assert (!NOTE_P (tmp)
- || NOTE_KIND (tmp) != NOTE_INSN_DELETED);
diff --git a/patches/gcc-4.3.2/generic/gentoo/66_all_gcc43-pr25343.patch b/patches/gcc-4.3.2/generic/gentoo/66_all_gcc43-pr25343.patch
deleted file mode 100644
index 15e645d..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/66_all_gcc43-pr25343.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-http://gcc.gnu.org/PR25343
-
-sniped from Debian
-
-2008-04-27 Roman Zippel <zippel@linux-m68k.org>
-
- * config/host-linux.c (TRY_EMPTY_VM_SPACE): Define for __mc68000__.
-
----
- gcc/config/host-linux.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-Index: gcc-4.3.1/gcc/config/host-linux.c
-===================================================================
---- gcc-4.3.1.orig/gcc/config/host-linux.c
-+++ gcc-4.3.1/gcc/config/host-linux.c
-@@ -84,6 +84,8 @@
- # define TRY_EMPTY_VM_SPACE 0x8000000000
- #elif defined(__sparc__)
- # define TRY_EMPTY_VM_SPACE 0x60000000
-+#elif defined(__mc68000__)
-+# define TRY_EMPTY_VM_SPACE 0x40000000
- #else
- # define TRY_EMPTY_VM_SPACE 0
- #endif
diff --git a/patches/gcc-4.3.2/generic/gentoo/74_all_sh-pr24836.patch b/patches/gcc-4.3.2/generic/gentoo/74_all_sh-pr24836.patch
deleted file mode 100644
index 436802b..0000000
--- a/patches/gcc-4.3.2/generic/gentoo/74_all_sh-pr24836.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-http://sourceforge.net/mailarchive/forum.php?thread_id=8959304&forum_id=5348
-http://gcc.gnu.org/PR24836
-
----
- gcc/configure | 2 +-
- gcc/configure.ac | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-Index: gcc-4.3.1/gcc/configure.ac
-===================================================================
---- gcc-4.3.1.orig/gcc/configure.ac
-+++ gcc-4.3.1/gcc/configure.ac
-@@ -2537,7 +2537,7 @@ foo: .long 25
- tls_first_minor=14
- tls_as_opt="-m64 -Aesame --fatal-warnings"
- ;;
-- sh-*-* | sh[34]-*-*)
-+ sh-*-* | sh[34]*-*-*)
- conftest_s='
- .section ".tdata","awT",@progbits
- foo: .long 25
-Index: gcc-4.3.1/gcc/configure
-===================================================================
---- gcc-4.3.1.orig/gcc/configure
-+++ gcc-4.3.1/gcc/configure
-@@ -14709,7 +14709,7 @@ foo: .long 25
- tls_first_minor=14
- tls_as_opt="-m64 -Aesame --fatal-warnings"
- ;;
-- sh-*-* | sh[34]-*-*)
-+ sh-*-* | sh[34]*-*-*)
- conftest_s='
- .section ".tdata","awT",@progbits
- foo: .long 25