summaryrefslogtreecommitdiffstats
Commit message (Collapse)AuthorAgeFilesLines
* ptxd_make_debian_version_ext: new debian versionstable/OSELAS.Toolchain-2018.02.xMichael Olbrich2019-05-061-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-m4: fix building on debian busterMichael Olbrich2019-05-062-0/+163
| | | | | | Patch imported from PTXdist upstream Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-gdb: fix building with python3.7Michael Olbrich2019-04-182-0/+68
| | | | | | Add upstream fix that fixes the build issue. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* make_deb: handle paths that contain '_'Michael Olbrich2019-04-181-3/+3
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* release 2018.02.0v2018.02.0Michael Olbrich2018-02-0917-17/+17
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* make_deb: use new homepageMichael Olbrich2018-02-091-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-gdb: use Python3 if enabledMichael Olbrich2018-02-091-0/+2
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* expand debian package versionMichael Olbrich2018-02-093-2/+23
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* uclibc: remove old configsMichael Olbrich2018-02-092-441/+0
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* remove old patchesMichael Olbrich2018-02-0939-10219/+0
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* update ptxconfigsMichael Olbrich2018-02-0918-567/+255
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | - removed toolchains: - arm-cortexa8-linux-gnueabi - arm-cortexa8-linux-gnueabihf - arm-cortexm3-uclinuxeabi - arm-cortexm4-uclinuxeabihf - newlib/arm-cortexm3-eabi - newlib/arm-cortexm4-eabihf - new toolchains: - arm-v7m-uclinuxeabi - arm-v7em-uclinuxeabihf - newlib/arm-v7m-eabi - newlib/arm-v7em-eabihf These are a more generic relacement of the corresponding cortexm3/cortexm4 toolchains. - update: - gdb 7.11 -> 8.1 - ptxdist 2016.06.0 -> 2018.02.0 - update: - gcc 5.4.0 -> 7.3.1 (7-20180201) - glibc 2.23 -> 2.27 - binutils 2.26 -> 2.30 - kernel 4.6 -> 4.15 - newlib 2.4.0 -> 2.5.0 - uclibc ng-1.0.14 -> ng-1.0.28 Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* uclibc: add config for uclibc-ng-1.0.28-arm-v7m-uclinuxeabiMichael Olbrich2018-02-081-0/+216
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* uclibc: add config for uclibc-ng-1.0.28-arm-v7em-uclinuxeabihfMichael Olbrich2018-02-081-0/+216
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* newlib-2.5.0 patchesMichael Olbrich2018-02-083-0/+29
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* glibc-2.27 patchesMichael Olbrich2018-02-084-0/+106
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* gcc-7-20180201 patchesMichael Olbrich2018-02-088-0/+270
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* binutils-2.30 patchesMichael Olbrich2018-02-083-0/+100
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: update to ptxdist-2018.02.0Michael Olbrich2018-02-081-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: --with(out)-fp is goneMichael Olbrich2018-02-081-3/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: support gcc-7.xMichael Olbrich2018-02-081-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: use gdb-8.1Michael Olbrich2018-02-081-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: update default glibc optionsMichael Olbrich2018-02-081-5/+3
| | | | | | | | - obsolete nls is still needed - enable strong stack protector - don't enable lock elision, it seems to cause various problems Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: support kernel 4.10+Michael Olbrich2018-02-081-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: enable build-id by defaultMichael Olbrich2018-02-081-0/+5
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* fixup_ptxconfigs.sh: generalize cortexm3/cortexm4 to v7m/v7emMichael Olbrich2018-02-081-6/+6
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* newlib: fix building with newer ptxdistMichael Olbrich2018-02-071-0/+8
| | | | | | This is needed to propagate configure options. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* glibc: addons are gone with glibc-2.27Michael Olbrich2018-02-072-8/+0
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* glibc-headers: fix building with newer ptxdistMichael Olbrich2018-02-051-0/+8
| | | | | | | PTXdist now enforces strict option checking. This must be disabled here, because --enable-hacker-mode is not a real option. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* glibc: cleanup rules & update configure optionsMichael Olbrich2018-02-052-14/+0
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-gcc: use tar.bz2 for linaro archives onlyMichael Olbrich2018-02-051-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* glibc: remove long gone cvs optionMichael Olbrich2018-02-051-1/+0
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* glibc: tls has not been optional for a long timeMichael Olbrich2018-02-052-12/+0
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-gcc-first: don't build libmpxMichael Olbrich2018-02-051-1/+4
| | | | | | | It is build by default on x86. It needs the cross compiler. It is not needed here and will be built with cross-gcc. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-elf2flt: update to version 20161212-gbbe423fae32aMichael Olbrich2018-02-052-22/+10
| | | | | | | There is no need to make the version configurable. Also, we can handle git now so use it instead of a manual snapshot. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-zlib: version bump 1.2.8 -> 1.2.11Michael Olbrich2018-02-051-3/+3
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-xz: version bump 5.2.2 -> 5.2.3Michael Olbrich2018-02-051-2/+7
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-mpfr: version bump 3.1.4 -> 4.0.0Michael Olbrich2018-02-051-2/+2
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-mpc: version bump 1.0.3 -> 1.1.0Michael Olbrich2018-02-051-3/+3
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-libelf: version bump 0.166 -> 0.170Michael Olbrich2018-02-051-3/+13
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-isl: version bump 0.16.1 -> 0.18Michael Olbrich2018-02-051-2/+2
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-gmp: version bump 6.1.0 -> 6.1.2Michael Olbrich2018-02-051-2/+2
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* host-expat: version bump 2.1.1 -> 2.2.5Michael Olbrich2018-02-051-4/+6
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cleanup: stripping may fail for some linker scriptsMichael Olbrich2018-02-051-1/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* set minimal kernel version to 3.10 for kernel headers 4.xMichael Grzeschik2016-11-2215-15/+15
| | | | | | | It seems choosing 3.18 as minimum kernel version was a bit optimistic. Signed-off-by: Michael Grzeschik <m.grzeschik@pengutronix.de> Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-gcc: don't try to filter out PTXCONF_DESTDIR if it's not setMichael Olbrich2016-06-301-0/+2
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* release 2016.06.0v2016.06.0Michael Olbrich2016-06-2219-19/+19
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* update ptxconfigsMichael Olbrich2016-06-2218-364/+705
| | | | | | | | | | | | | | | | | | | | | | | | | | | update ptxconfigs - removed toolchains: avr_gcc-4.3.2_libc-1.6.2_binutils-2.19.1a avr_gcc-4.4.3_libc-1.7.1_binutils-2.20.1 - new toolchains: arm-cortexm4-uclinuxeabihf - update: gdb 7.8.1 -> 7.11 ptxdist 2014.12.0 -> 2016.06.0 - update: glibc 2.20 -> 2.23 gcc 4.9.2 -> 5.4.0 kernel 3.16 -> 4.6 newlib 2.1.0 -> 2.4.0 uclibc 0.9.33.2 -> ng-1.0.14 All toolchains that used older versions of the specified packages have been removed. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* cross-gcc: remove BSP directory from builtin configure argumentsMichael Olbrich2016-06-221-0/+7
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* Makefile: generate deterministic dist archivesMichael Olbrich2016-06-221-0/+1
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
* uclibc: add config for uclibc-ng-1.0.14-arm-cortexm4-uclinuxeabihfMichael Olbrich2016-06-221-0/+220
| | | | Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>