summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBastian Krause <bst@pengutronix.de>2018-11-06 15:58:06 +0100
committerSascha Hauer <s.hauer@pengutronix.de>2018-11-07 08:40:23 +0100
commit5de629366ea272790e7cac370de1a5b9d5863ee5 (patch)
tree125fe8032e26f439e0809fbebb5e943098d51219
parent8635785af5a69ab23e78d47805838382efd68e88 (diff)
downloadbarebox-5de629366ea272790e7cac370de1a5b9d5863ee5.tar.gz
mtd: nand_denali: update compatible
190a1c6e47 ("dts: update to v4.18-rc3") changed the compatible of the Denali NAND controller. Update the compatible in the barebox driver accordingly. Signed-off-by: Bastian Krause <bst@pengutronix.de> Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
-rw-r--r--drivers/mtd/nand/nand_denali_dt.c2
1 files changed, 1 insertions, 1 deletions
diff --git a/drivers/mtd/nand/nand_denali_dt.c b/drivers/mtd/nand/nand_denali_dt.c
index 2c6b188..e302454 100644
--- a/drivers/mtd/nand/nand_denali_dt.c
+++ b/drivers/mtd/nand/nand_denali_dt.c
@@ -86,7 +86,7 @@ out_disable_clk:
static __maybe_unused struct of_device_id denali_nand_compatible[] = {
{
- .compatible = "denali,denali-nand-dt"
+ .compatible = "altr,socfpga-denali-nand"
}, {
/* sentinel */
}