summaryrefslogtreecommitdiffstats
path: root/common/image.c
Commit message (Expand)AuthorAgeFilesLines
* Merge branch 'for-next/misc'Sascha Hauer2020-05-141-3/+0
|\
| * treewide: remove references to CREDITSUwe Kleine-K├Ânig2020-04-271-3/+0
* | image: support 'powerpc' for mkimage architectureMasahiro Yamada2020-05-041-0/+1
|/
* uimage: add define for ARM64 architectureRaphael Poggi2016-07-061-0/+1
* bootm: Move bootm options to common/KconfigSascha Hauer2016-05-101-1/+1
* Merge branch 'for-next/remove-fsf-address'Sascha Hauer2012-10-031-4/+0
|\
| * Treewide: remove address of the Free Software FoundationSascha Hauer2012-09-171-4/+0
* | Add OpenRISC Image typeFranck Jullien2012-09-141-0/+2
|/
* move code now only used in mkimage to mkimageSascha Hauer2011-12-151-169/+0
* remove now unused uImage codeSascha Hauer2011-12-151-118/+0
* bootm: fix various memory leaksSascha Hauer2011-11-291-0/+1
* factor out iminfo commandSascha Hauer2011-11-291-1/+1
* image: move map_image amd unmap_image to image.cJean-Christophe PLAGNIOL-VILLARD2011-09-281-0/+121
* image: use data base addr for image_print_contents, image_multi_count/getimgJean-Christophe PLAGNIOL-VILLARD2011-09-281-16/+15
* image: remove confusing image_check_* functionsSascha Hauer2010-10-131-3/+4
* image: factorise image printing contentsJean-Christophe PLAGNIOL-VILLARD2010-10-081-0/+177
* Replace direct header access with the API routinesJean-Christophe PLAGNIOL-VILLARD2010-10-081-4/+4
* image: rename IH_CPU to IH_ARCH to be more concistantJean-Christophe PLAGNIOL-VILLARD2010-10-081-18/+18
* image: factorise string helperJean-Christophe PLAGNIOL-VILLARD2010-10-081-0/+134
* Revert "image: factorise string helper"Sascha Hauer2010-10-071-134/+0
* Revert "image: rename IH_CPU to IH_ARCH to be more concistant"Sascha Hauer2010-10-071-18/+18
* Revert "Replace direct header access with the API routines"Sascha Hauer2010-10-071-4/+4
* Revert "image: factorise image printing contents"Sascha Hauer2010-10-071-175/+0
* image: factorise image printing contentsJean-Christophe PLAGNIOL-VILLARD2010-09-241-0/+175
* Replace direct header access with the API routinesJean-Christophe PLAGNIOL-VILLARD2010-09-241-4/+4
* image: rename IH_CPU to IH_ARCH to be more concistantJean-Christophe PLAGNIOL-VILLARD2010-09-231-18/+18
* image: factorise string helperJean-Christophe PLAGNIOL-VILLARD2010-09-231-0/+134