summaryrefslogtreecommitdiffstats
path: root/scripts/mod/Makefile
diff options
context:
space:
mode:
authorUwe Kleine-König <u.kleine-koenig@pengutronix.de>2009-09-12 22:05:48 +0200
committerUwe Kleine-König <u.kleine-koenig@pengutronix.de>2009-09-12 22:05:48 +0200
commit01ae9e3573c2b218b31323c9e26553324649c28e (patch)
tree88a0bf2d8c45a7255c79c60a1d54757bb9faf2eb /scripts/mod/Makefile
downloaddebianrt-kbuild-01ae9e3573c2b218b31323c9e26553324649c28e.tar.gz
debianrt-kbuild-01ae9e3573c2b218b31323c9e26553324649c28e.tar.xz
svn://svn.debian.org/kernel/dists/trunk/linux-kbuild-2.6@13259
Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
Diffstat (limited to 'scripts/mod/Makefile')
-rw-r--r--scripts/mod/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/scripts/mod/Makefile b/scripts/mod/Makefile
new file mode 100644
index 0000000..0e01d9f
--- /dev/null
+++ b/scripts/mod/Makefile
@@ -0,0 +1,26 @@
+PROGS = \
+ modpost \
+ modpost.real-lsb-32 \
+ modpost.real-lsb-64 \
+ modpost.real-msb-32 \
+ modpost.real-msb-64
+
+OUTDIR = scripts/mod
+
+top_srcdir = ../..
+
+include $(top_srcdir)/Makefile.inc
+
+modpost.real-%:
+ $(MAKE) -f Makefile.real TYPE=$* SOURCEDIR=$(top_srcdir)/kbuild/scripts/mod
+
+%: %.o
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+modpost.h: $(top_srcdir)/kbuild/scripts/mod/modpost.c
+ python ./gendef.py $< > $@
+
+modpost.o: modpost.c modpost.h
+
+clean:
+ rm -f modpost.h