summaryrefslogtreecommitdiffstats
path: root/scripts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/Makefile')
-rw-r--r--scripts/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/scripts/Makefile b/scripts/Makefile
new file mode 100644
index 0000000..7359e5e
--- /dev/null
+++ b/scripts/Makefile
@@ -0,0 +1,46 @@
+PROGS = \
+ bin2c \
+ conmakehash \
+ kallsyms \
+ pnmtologo
+
+DATA = \
+ Kbuild.include \
+ Makefile.build \
+ Makefile.clean \
+ Makefile.host \
+ Makefile.lib \
+ Makefile.modinst \
+ Makefile.modpost \
+ mkversion
+
+SCRIPTS = \
+ checkincludes.pl \
+ checkstack.pl \
+ checkversion.pl \
+ gcc-version.sh \
+ gcc-x86_64-has-stack-protector.sh \
+ gen_initramfs_list.sh \
+ kernel-doc \
+ Lindent \
+ makelst \
+ mksysmap \
+ mkuboot.sh \
+ namespace.pl \
+ patch-kernel \
+ setlocalversion \
+ ver_linux
+
+SUBDIRS = \
+ basic \
+ genksyms \
+ kconfig \
+ mod
+
+OUTDIR = scripts
+
+top_srcdir = ..
+
+VPATH = $(top_srcdir)/kbuild/scripts
+
+include $(top_srcdir)/Makefile.inc