summaryrefslogtreecommitdiffstats
path: root/patches/bugfix/ia64/hardcode-arch-script-output.patch
diff options
context:
space:
mode:
Diffstat (limited to 'patches/bugfix/ia64/hardcode-arch-script-output.patch')
-rw-r--r--patches/bugfix/ia64/hardcode-arch-script-output.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/patches/bugfix/ia64/hardcode-arch-script-output.patch b/patches/bugfix/ia64/hardcode-arch-script-output.patch
new file mode 100644
index 0000000..7fb311b
--- /dev/null
+++ b/patches/bugfix/ia64/hardcode-arch-script-output.patch
@@ -0,0 +1,45 @@
+--- linux-source-2.6.18/arch/ia64/Makefile.orig 2007-01-03 17:26:31.000000000 -0700
++++ linux-source-2.6.18/arch/ia64/Makefile 2007-01-03 17:57:52.000000000 -0700
+@@ -28,16 +28,7 @@
+ -falign-functions=32 -frename-registers -fno-optimize-sibling-calls
+ CFLAGS_KERNEL := -mconstant-gp
+
+-GAS_STATUS = $(shell $(srctree)/arch/ia64/scripts/check-gas "$(CC)" "$(OBJDUMP)")
+-KBUILD_CPPFLAGS += $(shell $(srctree)/arch/ia64/scripts/toolchain-flags "$(CC)" "$(OBJDUMP)" "$(READELF)")
+-
+-ifeq ($(GAS_STATUS),buggy)
+-$(error Sorry, you need a newer version of the assember, one that is built from \
+- a source-tree that post-dates 18-Dec-2002. You can find a pre-compiled \
+- static binary of such an assembler at: \
+- \
+- ftp://ftp.hpl.hp.com/pub/linux-ia64/gas-030124.tar.gz)
+-endif
++KBUILD_CPPFLAGS += -DHAVE_WORKING_TEXT_ALIGN -DHAVE_MODEL_SMALL_ATTRIBUTE -DHAVE_SERIALIZE_DIRECTIVE
+
+ ifeq ($(call cc-version),0304)
+ cflags-$(CONFIG_ITANIUM) += -mtune=merced
+@@ -67,7 +58,7 @@
+
+ PHONY += boot compressed check
+
+-all: compressed unwcheck
++all: compressed
+
+ compressed: vmlinux.gz
+
+@@ -76,9 +67,6 @@
+ vmlinux.gz: vmlinux
+ $(Q)$(MAKE) $(build)=$(boot) $@
+
+-unwcheck: vmlinux
+- -$(Q)READELF=$(READELF) python $(srctree)/arch/ia64/scripts/unwcheck.py $<
+-
+ archclean:
+ $(Q)$(MAKE) $(clean)=$(boot)
+
+@@ -94,5 +82,4 @@
+ echo '* compressed - Build compressed kernel image'
+ echo ' install - Install compressed kernel image'
+ echo ' boot - Build vmlinux and bootloader for Ski simulator'
+- echo '* unwcheck - Check vmlinux for invalid unwind info'
+ endef