summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Kleine-König <u.kleine-koenig@pengutronix.de>2018-12-14 10:16:04 +0100
committerUwe Kleine-König <u.kleine-koenig@pengutronix.de>2018-12-14 10:16:04 +0100
commit8fe69186aae511688599b47bd4f4613ef485e03c (patch)
treefc25578d7bf702e4ea7c7997d717bec94f52c782
parent68cc543684b664979f2d09879da9b816fd60e43e (diff)
downloadpengutronix-archive-keyring-8fe69186aae511688599b47bd4f4613ef485e03c.tar.gz
pengutronix-archive-keyring-8fe69186aae511688599b47bd4f4613ef485e03c.tar.xz
README.md: some more fixes and details
-rw-r--r--README.md13
1 files changed, 11 insertions, 2 deletions
diff --git a/README.md b/README.md
index 51d89a0..9e509bd 100644
--- a/README.md
+++ b/README.md
@@ -44,6 +44,15 @@ last tag.
Optionally drop old keys by just deleting them.
+ $ oldyear=$(($year - 2))
+ $ if test -f pengutronix-archive-keyring-$oldyear.gpg; then
+ oldgpgid=$(gpg --list-key --with-colons "Pengutronix Archive Signing Key ($oldyear)" | awk -F: '$1 == "pub" { print $5 }')
+ git rm pengutronix-archive-keyring-$oldyear.gpg
+ dch -v $pkgversion "drop old key $oldgpgid for $oldyear"
+ git add debian/changelog
+ git commit -m "drop old key $oldgpgid for $oldyear"
+ fi
+
### build package
$ dch --release --distribution unstable ""
@@ -52,7 +61,7 @@ Optionally drop old keys by just deleting them.
Pitfall: In January 2018 when building the package on sid the result was not
installable on Wheezy and older because control.tar was compressed using xz
-which isn't supported by Wheezy's dpkg.
+which isn't supported by Wheezy's dpkg. Building in a Stretch chroot works fine.
### finalize git stuff
@@ -65,7 +74,7 @@ which isn't supported by Wheezy's dpkg.
$ reprepro --export=never include sid /path/to/pengutronix-archive-keyring_${pkgversion}_amd64.changes
$ for dist in $(sed -n 's/^Suite: //p' conf/distributions | grep -v unstable); do reprepro --export=never copy $dist sid pengutronix-archive-keyring; done
$ reprepro export
- $ gpg --export $gpgid /home/publish/sites/debian.pengutronix.de/DocumentRoot/debian/ptx-archive-key.gpg
+ $ gpg --export $gpgid > /home/publish/sites/debian.pengutronix.de/DocumentRoot/debian/ptx-archive-key.gpg
$ touch /home/publish/sites/__sync__/debian.pengutronix.de
### reminder for next keyupdate