summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0376d2d..136bc56 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,18 @@ fi
AC_ARG_VAR([JSON_DBUS_BRIDGE], [json-dbus-bridge FCGI application])
AC_SUBST(JSON_DBUS_BRIDGE)
+AC_PATH_PROGS([QMAKE],[qmake-qt4 qmake],,)
+if test -z "$QMAKE"; then
+ AC_MSG_ERROR([qmake (Qt4) not found. Define QMAKE=/path/to/qmake or make sure qmake is in \$PATH])
+fi
+"$QMAKE" -v 2>&1 | grep -q "Using Qt version 4"
+if test $? -ne 0 ; then
+ AC_MSG_ERROR([$QMAKE is not qmake from Qt4. Define QMAKE=/path/to/qmake or make sure the correct qmake is found.])
+fi
+AC_ARG_VAR([QMAKE], [qmake from Qt4])
+AC_SUBST(QMAKE)
+export QMAKE
+
AC_ARG_WITH([qooxdoo-sdk],AS_HELP_STRING([--with-qooxdoo-sdk=PATH], [Path to qooxdoo sdk]),
if test -x "$withval/tool/bin/generator.py"; then
QOOXDOO_SDK="$withval"
@@ -49,6 +61,7 @@ AC_CONFIG_FILES([
lighttpd/lighttpd.conf
services/Makefile
services/python/Makefile
+ services/qt4/Makefile
web-gui/Makefile
web-gui/hello-world/Makefile
web-gui/hello-world/config.json
@@ -64,6 +77,7 @@ AC_CONFIG_FILES([web-gui/hello-world/generate.py],[chmod +x web-gui/hello-world/
AC_CONFIG_FILES([web-gui/calculator/generate.py],[chmod +x web-gui/calculator/generate.py])
AC_CONFIG_FILES([web-gui/live/generate.py],[chmod +x web-gui/live/generate.py])
AC_CONFIG_FILES([web-gui/logging/generate.py],[chmod +x web-gui/logging/generate.py])
+AC_CONFIG_COMMANDS([services/qt4/dbus-info-service/Makefile], [(cd services/qt4/dbus-info-service && $QMAKE ../../../${srcdir}/services/qt4/dbus-info-service/dbus-info-service.pro)])
AC_OUTPUT