summaryrefslogtreecommitdiffstats
path: root/web-gui/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web-gui/Makefile.am')
-rw-r--r--web-gui/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/web-gui/Makefile.am b/web-gui/Makefile.am
index e0304e9..5cf8e07 100644
--- a/web-gui/Makefile.am
+++ b/web-gui/Makefile.am
@@ -3,9 +3,20 @@ SUBDIRS = \
hello-world \
calculator
+all: index.html
+
+index.html: index.sh
+ sh $< $(SUBDIRS) > $@
+
clean-local:
rm -rf qooxdoo-cache
+EXTRA_DIST = \
+ index.sh
+
+CLEANFILES = \
+ index.html
+
MAINTAINERCLEANFILES = \
Makefile.in