summaryrefslogtreecommitdiffstats
path: root/web-gui/plot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web-gui/plot/Makefile.am')
-rw-r--r--web-gui/plot/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/web-gui/plot/Makefile.am b/web-gui/plot/Makefile.am
new file mode 100644
index 0000000..c14bdeb
--- /dev/null
+++ b/web-gui/plot/Makefile.am
@@ -0,0 +1,39 @@
+
+QOOXDOO_SOURCE = \
+ Manifest.json \
+ generate.py \
+ source/resource/plot/back.png \
+ source/index.html \
+ source/translation/readme.txt \
+ source/class/plot/Application.js \
+ source/class/plot/test/DemoTest.js \
+ source/class/plot/theme/Color.js \
+ source/class/plot/theme/Theme.js \
+ source/class/plot/theme/Decoration.js \
+ source/class/plot/theme/Font.js \
+ source/class/plot/theme/Appearance.js
+
+JS_3RDPARTY = \
+ build/script/jquery-1.4.2.min.js \
+ build/script/jquery.flot.min.js
+
+build/script/jquery-1.4.2.min.js:
+ @install -D -m644 ${srcdir}/3rdparty/jquery/jquery-1.4.2.min.js $@
+
+build/script/jquery.flot.min.js:
+ @install -D -m644 ${srcdir}/3rdparty/flot/jquery.flot.min.js $@
+
+all: $(JS_3RDPARTY)
+ ./generate.py build
+
+clean-local:
+ rm -rf build
+
+EXTRA_DIST = \
+ config.json.in \
+ $(QOOXDOO_SOURCE) \
+ $(JS_3RDPARTY)
+
+MAINTAINERCLEANFILES = \
+ Makefile.in
+