summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAhmad Fatoum <a.fatoum@pengutronix.de>2019-03-05 14:45:46 +0100
committerEnrico Jorns <e.joerns@tu-bs.de>2019-03-15 09:15:07 +0100
commit08082fbf8124f59f31d76ce6377f5e7c82b3e33d (patch)
tree476a04dcb3c9e56b005b010ae53da6353881f7b9
parentd3e4f4904c4fbb3d1677f74903123fd7c2649fb6 (diff)
downloadmeta-ptx-08082fbf8124f59f31d76ce6377f5e7c82b3e33d.tar.gz
meta-ptx-08082fbf8124f59f31d76ce6377f5e7c82b3e33d.tar.xz
barebox: add bison and flex build dependencies
Both lex/yacc or compatibles are now dependencies of the barebox build process, same as the kernel's. They are used since 273dbe5f8 contained in barebox v2019.02.0 for generating the Kconfig lexer and parser. Adding flex-native and bison-native to DEPENDS addresses this and fixes the currently failing barebox v2019.02.0 do_configure stage: | DEBUG: Executing shell function do_configure | NOTE: make CROSS_COMPILE=arm-ptx-linux-gnueabi- oldconfig | YACC scripts/kconfig/zconf.tab.c | /bin/sh: 1: bison: not found | scripts/Makefile.lib:194: recipe for target 'scripts/kconfig/zconf.tab.c' failed | make[1]: *** [scripts/kconfig/zconf.tab.c] Error 127 | Makefile:416: recipe for target 'oldconfig' failed | make: *** [oldconfig] Error 2 Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
-rw-r--r--recipes-bsp/barebox/barebox.inc2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/barebox/barebox.inc b/recipes-bsp/barebox/barebox.inc
index 34d12a5..8efeff5 100644
--- a/recipes-bsp/barebox/barebox.inc
+++ b/recipes-bsp/barebox/barebox.inc
@@ -11,7 +11,7 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit kernel-arch deploy
inherit cml1
-DEPENDS = "libusb1-native lzop-native"
+DEPENDS = "libusb1-native lzop-native bison-native flex-native"
PACKAGES += "${PN}-bareboxenv ${PN}-bareboxcrc32 ${PN}-kernel-install \
${PN}-bareboximd"