summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAhmad Fatoum <a.fatoum@pengutronix.de>2018-11-29 10:53:05 +0100
committerEnrico Jorns <e.joerns@tu-bs.de>2018-12-11 22:55:16 +0100
commit3e4ad9324f0dd7a1671ee77c8aa57e170fae3768 (patch)
treec33b7ed9baefbc15288155021bdf2aa9647f715d
parent4e7c9259c9b6b66349220b200ece363ec369eec8 (diff)
downloadmeta-ptx-3e4ad9324f0dd7a1671ee77c8aa57e170fae3768.tar.gz
meta-ptx-3e4ad9324f0dd7a1671ee77c8aa57e170fae3768.tar.xz
recipes: ptx-profile: rename ptx-profile to 00-ptx.sh
krogoth-15.0.0-148-g0aba7d5d36c0 changed /etc/profile to only source /etc/profile.d/*.sh Amend the extension and while at it rename it to 00-ptx.sh instead. The 00- prefix makes for easy overriding. The -profile suffix was removed as it seems redundant when installed inside /etc/profile.d/. Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de>
-rw-r--r--recipes-core/ptx-profile/ptx-profile.bb6
-rw-r--r--recipes-core/ptx-profile/ptx-profile/00-ptx.sh (renamed from recipes-core/ptx-profile/ptx-profile/ptx-profile)0
2 files changed, 3 insertions, 3 deletions
diff --git a/recipes-core/ptx-profile/ptx-profile.bb b/recipes-core/ptx-profile/ptx-profile.bb
index 03d78a3..685913f 100644
--- a/recipes-core/ptx-profile/ptx-profile.bb
+++ b/recipes-core/ptx-profile/ptx-profile.bb
@@ -2,13 +2,13 @@ DESCRIPTION = "PTX distro specific profile"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
-SRC_URI = "file://ptx-profile"
+SRC_URI = "file://00-ptx.sh"
S = "${WORKDIR}"
do_install () {
install -d ${D}${sysconfdir}/profile.d/
- install -m 0755 ${S}/ptx-profile ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${S}/00-ptx.sh ${D}${sysconfdir}/profile.d/
}
-FILES_${PN} = "${sysconfdir}/profile.d/ptx-profile"
+FILES_${PN} = "${sysconfdir}/profile.d/00-ptx.sh"
diff --git a/recipes-core/ptx-profile/ptx-profile/ptx-profile b/recipes-core/ptx-profile/ptx-profile/00-ptx.sh
index ba3dfb9..ba3dfb9 100644
--- a/recipes-core/ptx-profile/ptx-profile/ptx-profile
+++ b/recipes-core/ptx-profile/ptx-profile/00-ptx.sh