summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/packagegroups/packagegroup-core-boot.bbappend1
-rw-r--r--recipes-core/ptx-profile/ptx-profile.bb14
-rw-r--r--recipes-core/ptx-profile/ptx-profile/ptx-profile13
3 files changed, 28 insertions, 0 deletions
diff --git a/recipes-core/packagegroups/packagegroup-core-boot.bbappend b/recipes-core/packagegroups/packagegroup-core-boot.bbappend
new file mode 100644
index 0000000..55a3e73
--- /dev/null
+++ b/recipes-core/packagegroups/packagegroup-core-boot.bbappend
@@ -0,0 +1 @@
+RDEPENDS_${PN} += "ptx-profile"
diff --git a/recipes-core/ptx-profile/ptx-profile.bb b/recipes-core/ptx-profile/ptx-profile.bb
new file mode 100644
index 0000000..03d78a3
--- /dev/null
+++ b/recipes-core/ptx-profile/ptx-profile.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "PTX distro specific profile"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+SRC_URI = "file://ptx-profile"
+
+S = "${WORKDIR}"
+
+do_install () {
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${S}/ptx-profile ${D}${sysconfdir}/profile.d/
+}
+
+FILES_${PN} = "${sysconfdir}/profile.d/ptx-profile"
diff --git a/recipes-core/ptx-profile/ptx-profile/ptx-profile b/recipes-core/ptx-profile/ptx-profile/ptx-profile
new file mode 100644
index 0000000..ba3dfb9
--- /dev/null
+++ b/recipes-core/ptx-profile/ptx-profile/ptx-profile
@@ -0,0 +1,13 @@
+# /etc/profile.environment - config for sub-shells
+PS1="\\u@\\h:\\w "
+PS2=" >"
+PS4="+ "
+
+alias vim='vi'
+alias l='ls -l'
+alias ll='ls -al'
+alias ..='cd ..'
+alias ...='cd ../..'
+alias md='mkdir'
+alias rd='rmdir'
+