summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2008-12-19 10:55:09 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2008-12-19 10:55:09 +0000
commit5307f3ce9383a08e7e8d0e2028b1b6c85d5397f0 (patch)
treed4b9b94dce4f71929b1498ae35f8bdc30e685438 /configure.ac
parent211af88adbc4414d9ce4fd6a79cb7250877b98dc (diff)
downloadptxdist-5307f3ce9383a08e7e8d0e2028b1b6c85d5397f0.tar.gz
ptxdist-5307f3ce9383a08e7e8d0e2028b1b6c85d5397f0.tar.xz
* configure.ac:
check for makeinfo git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@9246 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 954e3bec7..449af0ca9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -39,7 +39,7 @@ CONF_LIBS=${LIBS}
AC_SUBST(CONF_LIBS)
AC_SEARCH_LIBS(mvaddch, [ncurses curses pdcurses], CURSES_LIB=$ac_lib,
- AC_MSG_ERROR([curses library required.]))
+ [AC_MSG_ERROR([ncurses development library not found, please install libncurses-dev])])
MCONF_LIBS=${LIBS}
AC_SUBST(MCONF_LIBS)
@@ -177,6 +177,12 @@ case "${YACC_VERSION}" in
AC_MSG_RESULT([$YACC_VERSION]) ;;
esac
+dnl Check for makeinfo
+AC_PATH_PROGS(MAKEINFO, makeinfo,, $PATH)
+if test -z "$MAKEINFO"; then
+ AC_MSG_ERROR([makeinfo could not be found, please install the texinfo package])
+fi
+
dnl Check for bunzip2
AC_PATH_PROGS(BUNZIP2, bunzip2,, $PATH)
if test -z "$BUNZIP2"; then