summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWolfram Sang <w.sang@pengutronix.de>2008-12-11 16:52:19 +0000
committerWolfram Sang <w.sang@pengutronix.de>2008-12-11 16:52:19 +0000
commit14fc5b200c2274b1681b0340d83dd71f83fa8554 (patch)
tree0e45be3050281f2e0225f058704ff4fe13ea5d87 /configure.ac
parent95911e5ed0614959e34bbf64cfe698e1e743aa69 (diff)
downloadptxdist-14fc5b200c2274b1681b0340d83dd71f83fa8554.tar.gz
ptxdist-14fc5b200c2274b1681b0340d83dd71f83fa8554.tar.xz
* bash_completion: install it using autotools
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@9213 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14203c3cf..14770d886 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,6 +364,23 @@ dnl Check for rpmbuild (v4) vs. rpm (v3)
dnl AC_PATH_PROGS(RPMBUILD, [rpmbuild rpm])
dnl AC_SUBST(RPMBUILD)
+dnl check if bash completion is desired (adapted from 'source-highlight' by Lorenzo Bettini)
+dnl don't use sysconfdir! as bash_completion does not check multiple directories, we use the system default
+
+AC_ARG_WITH([bash-completion],
+ AS_HELP_STRING([--with-bash-completion@<:@=DIR@:>@], [install bash_completion file (default: yes) - optionally specify bash_completion directory (default: /etc/bash_completion.d)]),
+ [
+ if test "$withval" = "no"; then
+ BASH_COMPLETION_DIR=""
+ elif test "$withval" = "yes"; then
+ BASH_COMPLETION_DIR=/etc/bash_completion.d
+ else
+ BASH_COMPLETION_DIR="$withval"
+ fi
+ ],
+ [BASH_COMPLETION_DIR=/etc/bash_completion.d]
+)
+AC_SUBST(BASH_COMPLETION_DIR)
dnl
dnl versions