summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJuergen Beisert <jbe@pengutronix.de>2012-06-13 17:23:39 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2012-06-13 19:20:25 +0200
commit26e6bae73dbe768d0db1ae18004db8533e33aaac (patch)
tree076accb7f6a48ef64ffaf24ecdde283aee4a0ad3 /configure.ac
parenta3fac1e00ce95131e633bf7e72d973a33267dc26 (diff)
downloadptxdist-26e6bae73dbe768d0db1ae18004db8533e33aaac.tar.gz
ptxdist-26e6bae73dbe768d0db1ae18004db8533e33aaac.tar.xz
'xargs' is from findutils. So, handle it like all other findutils tools
Signed-off-by: Juergen Beisert <jbe@pengutronix.de> Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 1 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index defa1b4b7..e76f60cfc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,7 @@ GNU_TOOL(cat, coreutils)
GNU_TOOL(readlink, coreutils)
GNU_TOOL(tar, tar)
GNU_TOOL(find, findutils)
+GNU_TOOL(xargs, findutils)
dnl Check for egrep
AC_PROG_EGREP
@@ -259,19 +260,6 @@ case "$FIND_VERSION" in
esac
AC_MSG_RESULT([$FIND_VERSION])
-dnl Check for xargs
-AC_PATH_PROGS(XARGS, xargs,, $PATH)
-if test -z "$XARGS"; then
- AC_MSG_ERROR([xargs could not be found, please install])
-fi
-
-AC_MSG_CHECKING([if xargs -r works as expected])
-echo | ${XARGS} -r false
-if test $? -ne 0; then
- AC_MSG_ERROR([xargs with "-r" support needed, please install GNU xargs (unsually located in the "findutils" package])
-fi
-AC_MSG_RESULT([ok])
-
dnl Check for make
AC_PATH_PROGS(MAKE, gmake gnumake make,, $PATH)
if test -z "$MAKE"; then