summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Bießmann <andreas@biessmann.de>2014-04-23 11:15:08 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2014-04-23 14:34:21 +0200
commit458c34f01719a16020b0953d5af687f26eee3a68 (patch)
treeaf6764d9a77219c3bfc9cf97bc88d77305159a16 /configure.ac
parent59e84e62ca4df6e6609ca02bfdc02a5c0ee7536b (diff)
downloadptxdist-458c34f01719a16020b0953d5af687f26eee3a68.tar.gz
ptxdist-458c34f01719a16020b0953d5af687f26eee3a68.tar.xz
configure: consolidate compiler checks
Remove redundant check for GCC and move compiler checks to the beginning. Before the AC_HEADERS_STDC checked for compilers implicitly and later on we checked again explicitly for them. Signed-off-by: Andreas Bießmann <andreas@biessmann.de> Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 5 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 390fcaf95..22c8df03a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,11 @@ else
AC_MSG_ERROR([install the ptxdist-patches archive into the same directory as ptxdist.])
fi
+dnl
+dnl Check for C and C++ compilers
+dnl
+AC_PROG_CC
+AC_PROG_CXX
dnl
dnl Check header files, mostly for lxdialog & kconfig
@@ -160,18 +165,6 @@ GNU_TOOL(xargs, findutils)
dnl Check for egrep
AC_PROG_EGREP
-dnl Check for gcc
-AC_PROG_CC
-if test -z "$CC"; then
- AC_MSG_ERROR([gcc could not be found, please install])
-fi
-
-dnl Check for g++
-AC_PROG_CXX
-if test -z "$CXX"; then
- AC_MSG_ERROR([g++ could not be found, please install])
-fi
-
dnl Check for awk
AC_PROG_AWK
AC_PATH_PROGS(AWK, ${AWK},)
@@ -285,9 +278,6 @@ if test -z "$MSGFMT"; then
AC_MSG_ERROR([gettext could not be found, please install])
fi
-dnl Check for gcc
-AC_PATH_PROGS(GCC, gcc,, $PATH)
-
dnl
dnl Checks for Python, needed for ipkg-utils
dnl