summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2008-05-16 10:33:43 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2008-05-16 10:33:43 +0000
commit7fa1229d0cce2cbbdc4c718b9e5fc88e9e48552f (patch)
treeaddc9412702b5e5158aa5b0e85594086f11973da /configure.ac
parent1f06369182fb411fc872916e0e14f82465f3aabe (diff)
downloadptxdist-7fa1229d0cce2cbbdc4c718b9e5fc88e9e48552f.tar.gz
ptxdist-7fa1229d0cce2cbbdc4c718b9e5fc88e9e48552f.tar.xz
* configure.ac:
added test against old version of bison git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@8162 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74d9e80be..bc44cc021 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,6 +158,17 @@ if test -z "${YACC}"; then
AC_MSG_ERROR([yacc/bison could not be found, please install])
fi
+AC_MSG_CHECKING([yacc/bison version])
+YACC_VERSION=`$YACC --version 2>/dev/null | $SED -ne "s/.*GNU Bison.* \([[0-9.]]*\).*/\1/p"`
+case "${YACC_VERSION}" in
+ 1.*)
+ AC_MSG_ERROR([$YACC_VERSION, your bison version is too old, install 2.3 or sth. like that]) ;;
+ "")
+ AC_MSG_WARN([no GNU bison found, continuing anyway....]) ;;
+ *)
+ AC_MSG_RESULT([$YACC_VERSION]) ;;
+esac
+
dnl Check for bunzip2
AC_PATH_PROGS(BUNZIP2, bunzip2,, $PATH)
if test -z "$BUNZIP2"; then