summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2008-05-16 12:05:13 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2008-05-16 12:05:13 +0000
commit9609f2efb7cba8a59be9d9ecde0a906c08945815 (patch)
tree977aff5da5cb1efcd51c46e004540bb5b55bbfce /configure.ac
parent7fa1229d0cce2cbbdc4c718b9e5fc88e9e48552f (diff)
downloadptxdist-9609f2efb7cba8a59be9d9ecde0a906c08945815.tar.gz
ptxdist-9609f2efb7cba8a59be9d9ecde0a906c08945815.tar.xz
* configure.ac:
check against bison++ git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@8165 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bc44cc021..3d4897cda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -158,6 +158,14 @@ if test -z "${YACC}"; then
AC_MSG_ERROR([yacc/bison could not be found, please install])
fi
+
+AC_MSG_CHECKING([whether yacc is bison++])
+if $YACC --version | grep bison++ -q; then
+ AC_MSG_ERROR([your $YACC turns out to be bison++, please install plain bison])
+else
+ AC_MSG_RESULT([no, this is good])
+fi
+
AC_MSG_CHECKING([yacc/bison version])
YACC_VERSION=`$YACC --version 2>/dev/null | $SED -ne "s/.*GNU Bison.* \([[0-9.]]*\).*/\1/p"`
case "${YACC_VERSION}" in