summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Schwebel <r.schwebel@pengutronix.de>2006-10-23 16:15:22 +0000
committerRobert Schwebel <r.schwebel@pengutronix.de>2006-10-23 16:15:22 +0000
commit07482abd89ce9fabbdb184b48b209bd64eccc22b (patch)
treeec89bec5bff69534ba2a88670501ec1c00d13ea5 /configure.ac
parent3964a0ad486383813f5171cc2aa66e86f32f4750 (diff)
downloadptxdist-07482abd89ce9fabbdb184b48b209bd64eccc22b.tar.gz
ptxdist-07482abd89ce9fabbdb184b48b209bd64eccc22b.tar.xz
* configure: added check for patches/ directory
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@6214 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 925fb0575..c1a5b173e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,20 @@ PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
dnl
+dnl Check if the user has extracted the patches archive
+dnl
+
+AC_MSG_CHECKING(for ptxdist patches)
+if test -d `dirname $0`/patches
+then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([install the ptxdist-patches archive into the same directory as ptxdist.],[1])
+fi
+
+
+dnl
dnl Check header files, mostly for lxdialog & kconfig
dnl