summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2006-11-03 15:17:49 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2006-11-03 15:17:49 +0000
commit11497198f6c614d1ae41f3c4fc21f7c51da5576e (patch)
tree05c0fda6987401cb8a9581a60fc79dfe6e90ae12 /configure.ac
parent3a47c748557e5912288ac09b47f73ffbb2bb78c6 (diff)
downloadptxdist-11497198f6c614d1ae41f3c4fc21f7c51da5576e.tar.gz
ptxdist-11497198f6c614d1ae41f3c4fc21f7c51da5576e.tar.xz
* configure.ac:
fail if lex yacc/bison or make are missing git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@6276 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e475b6e6..9994f69d5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -120,12 +120,14 @@ AC_MSG_RESULT([$AWK_VERSION])
dnl Check for lex
AC_PROG_LEX
+AC_PATH_PROGS(LEX, ${LEX},, $PATH)
if test -z "${LEX}"; then
AC_MSG_ERROR([(f)lex could not be found, please install])
fi
dnl Check for yacc
AC_PROG_YACC
+AC_PATH_PROGS(YACC, ${YACC},, $PATH)
if test -z "${YACC}"; then
AC_MSG_ERROR([yacc/bison could not be found, please install])
fi
@@ -216,6 +218,12 @@ if test -z "$EXPECT"; then
AC_MSG_ERROR([expect could not be found, please install])
fi
+dnl Check for make
+AC_PATH_PROGS(MAKE, gmake gnumake make,, $PATH)
+if test -z "$MAKE"; then
+ AC_MSG_ERROR([make could not be found, please install])
+fi
+
dnl Check for gcc
AC_PATH_PROGS(GCC, gcc,, $PATH)