summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRobert Schwebel <r.schwebel@pengutronix.de>2006-04-05 13:36:42 +0000
committerRobert Schwebel <r.schwebel@pengutronix.de>2006-04-05 13:36:42 +0000
commit204396a0c8787635800f7023a1f8d9045b4311b0 (patch)
tree9978304d359cee00a24217a352cf9080174d4daf /configure.ac
parentd93d83754905f2976902780acbb5decb63525595 (diff)
downloadptxdist-204396a0c8787635800f7023a1f8d9045b4311b0.tar.gz
ptxdist-204396a0c8787635800f7023a1f8d9045b4311b0.tar.xz
re-added checks for bunzip2, gunzip and readlink
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-0.10-trunk@5360 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 8b83e70f6..6d3b6db85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,9 +64,10 @@ version of bash from ftp.gnu.org
])
fi
+dnl
dnl Check for sed
-dnl FIXME: which version do we need and how do we find out if it
-dnl supports inplace?
+dnl FIXME: we need sed >= 4.0 which supports inplace
+dnl
AC_ARG_WITH(sed, AC_HELP_STRING(
[--with-sed], [name of the sed executable to use]),
[
@@ -78,6 +79,15 @@ AC_ARG_WITH(sed, AC_HELP_STRING(
AC_SUBST(SED)
])
+dnl Check for bunzip2
+AC_PATH_PROGS(bunzip2, bunzip2, , $PATH)
+
+dnl Check for gunzip
+AC_PATH_PROGS(gunzip, gunzip, , $PATH)
+
+dnl Check for readlink
+AC_PATH_PROGS(readlink, readlink, , $PATH)
+
dnl Check for awk
AC_ARG_WITH(awk, AC_HELP_STRING(
[--with-awk], [name of the awk executable to use]),