summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2006-06-20 07:33:36 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2006-06-20 07:33:36 +0000
commit334eff67d810e010a6b736e1959915ce97c1d75b (patch)
treed34f3513c4485ce851e904aa2a5d9ad787181a68 /configure.ac
parent3f12ff91c775ec1b25a5be194c45ac71beffffe2 (diff)
downloadptxdist-334eff67d810e010a6b736e1959915ce97c1d75b.tar.gz
ptxdist-334eff67d810e010a6b736e1959915ce97c1d75b.tar.xz
* configure.ac:
bail out if tools are mussing git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-0.10-trunk@5831 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2a276f8cf..4be8b11fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,12 +24,24 @@ AC_CHECK_HEADER(
AC_MSG_ERROR([Cannot find ncurses.h. Please install the ncurses development packet.])
)
-AC_PROG_LEX
AC_PROG_AWK
AC_PROG_EGREP
AC_PROG_INSTALL
+
+AC_PROG_LEX
+if test -z "${LEX}"; then
+ AC_MSG_ERROR([(f)lex could not be found, please install])
+fi
+
AC_PROG_YACC
+if test -z "${YACC}"; then
+ AC_MSG_ERROR([yacc/bison could not be found, please install])
+fi
+
PKG_PROG_PKG_CONFIG
+if test -z "${PKG_CONFIG}"; then
+ AC_MSG_ERROR([pkg-config could not be found, please install])
+fi
AC_SYS_INTERPRETER
if test "$interpval" != yes ; then