summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2006-06-23 13:02:48 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2006-06-23 13:02:48 +0000
commit6234c0354c5a72ef89b6a0647143f1c5be850567 (patch)
tree7d36f36ab39253778381a4968739211820b5f7bc /configure.ac
parentde1ca72122f192b4fe91a241a9731e2185028e4b (diff)
downloadptxdist-6234c0354c5a72ef89b6a0647143f1c5be850567.tar.gz
ptxdist-6234c0354c5a72ef89b6a0647143f1c5be850567.tar.xz
* configure.ac:
replaced pkg-config test by version that works even with old pkg-configs git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-0.10-trunk@5863 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 4be8b11fb..c7df32f64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,11 +38,6 @@ if test -z "${YACC}"; then
AC_MSG_ERROR([yacc/bison could not be found, please install])
fi
-PKG_PROG_PKG_CONFIG
-if test -z "${PKG_CONFIG}"; then
- AC_MSG_ERROR([pkg-config could not be found, please install])
-fi
-
AC_SYS_INTERPRETER
if test "$interpval" != yes ; then
AC_MSG_WARN([no
@@ -98,35 +93,41 @@ esac
AC_MSG_RESULT([$SED_VERSION])
dnl Check for bunzip2
-AC_PATH_PROGS( BUNZIP2, bunzip2, , $PATH)
+AC_PATH_PROGS(BUNZIP2, bunzip2, , $PATH)
if test -z "$BUNZIP2"; then
AC_MSG_ERROR([bunzip2 could not be found, please install])
fi
dnl Check for gunzip
-AC_PATH_PROGS( GUNZIP, gunzip, , $PATH)
+AC_PATH_PROGS(GUNZIP, gunzip, , $PATH)
if test -z "$GUNZIP"; then
AC_MSG_ERROR([gunzip could not be found, please install])
fi
dnl Check for readlink
-AC_PATH_PROGS( READLINK, readlink, , $PATH)
+AC_PATH_PROGS(READLINK, readlink, , $PATH)
if test -z "$READLINK"; then
AC_MSG_ERROR([readlink could not be found, please install])
fi
dnl Check for awk
-AC_PATH_PROGS( AWK, awk, , $PATH)
+AC_PATH_PROGS(AWK, awk, , $PATH)
if test -z "$AWK"; then
AC_MSG_ERROR([awk could not be found, please install])
fi
dnl Check for mktemp
-AC_PATH_PROGS( MKTEMP, mktemp, , $PATH)
+AC_PATH_PROGS(MKTEMP, mktemp, , $PATH)
if test -z "$MKTEMP"; then
AC_MSG_ERROR([mktemp could not be found, please install])
fi
+dnl Check for pkgconfig
+AC_PATH_PROGS(PKG_CONFIG, pkg-config, , $PATH)
+if test -z "${PKG_CONFIG}"; then
+ AC_MSG_ERROR([pkg-config could not be found, please install])
+fi
+
dnl
dnl Checks for python, needed for ipkg-utils
dnl