summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLuotao Fu <l.fu@pengutronix.de>2007-05-04 15:20:40 +0000
committerLuotao Fu <l.fu@pengutronix.de>2007-05-04 15:20:40 +0000
commita676f8056b0a0ac024e811ce0acb31df0678c029 (patch)
treed7ae4265be36ba4b975f241727315bbbdc77ffa6 /configure.ac
parentab673f3fce81ea39f43bea25aeaed0c59a7bd5af (diff)
downloadptxdist-a676f8056b0a0ac024e811ce0acb31df0678c029.tar.gz
ptxdist-a676f8056b0a0ac024e811ce0acb31df0678c029.tar.xz
added checking for extra python devel files due to stupidness in SuSE package management
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@7149 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a28590060..c220444e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,6 +278,16 @@ else
AC_MSG_ERROR(Please install the Python distutils package)
fi
+AC_MSG_CHECKING(whether python development files are present)
+PYTHON_CONFDIR=`$PYTHON -v -c "import distutils" 2>&1 | $EGREP distutils | $EGREP directory | $SED -ne "s/^[[^\/]]*\([[^[:space:]]]*\).*/\1/p"`/../config/
+if test -e "$PYTHON_CONFDIR/Makefile"; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([some python development files could not be found, you are
+ likely using suse or redhat system as host. In this case
+ please install the python-devel packages])
+fi
dnl Check for patch
AC_ARG_WITH(patch, AC_HELP_STRING(