summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJuergen Borleis <jbe@pengutronix.de>2015-06-01 15:27:28 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2015-12-03 22:37:00 +0100
commite24670248e11ff0e9b1c8c9ae3274e7139572e9d (patch)
treef4a729b2c2d2cf262541c2d3c7e8d2ad8271f4dd /configure.ac
parent223ad19162fdea43cf17f1507de233a5e397f36a (diff)
downloadptxdist-e24670248e11ff0e9b1c8c9ae3274e7139572e9d.tar.gz
ptxdist-e24670248e11ff0e9b1c8c9ae3274e7139572e9d.tar.xz
Add documentation support
Signed-off-by: Juergen Borleis <jbe@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e539f87db..640974a42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,6 +279,15 @@ if test -z "$MSGFMT"; then
AC_MSG_ERROR([gettext could not be found, please install])
fi
+AC_PATH_PROG(SPHINX, sphinx-build,, $PATH)
+if test -z "$SPHINX"; then
+ AC_MSG_NOTICE([sphinx not found, required to build the documentation])
+ SPHINX=sphinx-build
+else
+ AC_MSG_NOTICE([sphinx found, run 'make docs' to get documentation])
+fi
+AC_SUBST(SPHINX)
+
dnl
dnl Checks for Python, needed for ipkg-utils
dnl