summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLadislav Michl <ladis@linux-mips.org>2007-12-07 10:07:37 +0000
committerLadislav Michl <ladis@linux-mips.org>2007-12-07 10:07:37 +0000
commite5a95a069546915b1cf9b53967fe6ff54918d029 (patch)
treed19fd97806089217bc1ac3d90fdec236a3647af0 /configure.ac
parent297102f6801c327d4b25403819c3f5c6d8b67468 (diff)
downloadptxdist-e5a95a069546915b1cf9b53967fe6ff54918d029.tar.gz
ptxdist-e5a95a069546915b1cf9b53967fe6ff54918d029.tar.xz
Use linux-2.6.23 kconfig.
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@7642 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 24 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 4d57881aa..24389dda8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,11 +32,30 @@ dnl Check header files, mostly for lxdialog & kconfig
dnl
AC_HEADER_STDC
-AC_CHECK_HEADER(
- [ncurses.h],
- [],
- AC_MSG_ERROR([Cannot find ncurses.h. Please install the ncurses development packet.])
-)
+
+AC_CHECK_LIB([curses], [mvaddch], [CURSES_LIB='curses'])
+AC_CHECK_LIB([ncurses], [mvaddch], [CURSES_LIB='ncurses'])
+AC_CHECK_LIB([pdcurses], [mvaddch], [CURSES_LIB='pdcurses'])
+if test "$CURSES_LIB" = ""
+then
+ AC_MSG_ERROR([No curses library found.])
+fi
+if test "$CURSES_LIB" = "ncurses"
+then
+ AC_CHECK_HEADER(
+ [ncurses.h],
+ [CURSES_LOC='<ncurses.h>'],
+ AC_MSG_ERROR([Cannot find ncurses.h.])
+ )
+else
+ AC_CHECK_HEADER(
+ [curses.h],
+ [CURSES_LOC='<curses.h>'],
+ AC_MSG_ERROR([Cannot find curses.h.])
+ )
+fi
+AC_SUBST(CURSES_LOC)
+AC_SUBST(CURSES_LIB)
AC_SYS_INTERPRETER
if test "$interpval" != yes ; then