summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2009-05-28 13:25:37 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2009-05-28 13:25:37 +0000
commitf1bc4e3a093bd98173f047e5b03bdef287b4bcea (patch)
tree8fb26b8d5526e878cd5905622b025e4cd55fff5c /configure.ac
parentc2471e72e049dfefac6db15174fe866806b133e2 (diff)
downloadptxdist-f1bc4e3a093bd98173f047e5b03bdef287b4bcea.tar.gz
ptxdist-f1bc4e3a093bd98173f047e5b03bdef287b4bcea.tar.xz
clean up ptxdist's build system
Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de> git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@10595 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 9 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index c7ba1ee19..c910edb41 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,33 +2,29 @@ dnl
dnl Process this file with autoconf to produce a configure script.
dnl Most parts of this configure script have been borrowed from quilt.
dnl
-
-AC_INIT([ptxdist],[1.99.svn],[ptxdist@pengutronix.de])
-AC_CONFIG_AUX_DIR(autoconf)
AC_PREREQ(2.59)
-AC_REVISION ($Revision: 1.38 $)
-PACKAGE_RELEASE=1
-AC_SUBST(PACKAGE_RELEASE)
+AC_INIT([ptxdist],[1.99.svn],[ptxdist@pengutronix.de])
+AC_CONFIG_AUX_DIR(scripts/autoconf)
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
dnl
dnl Check if the user has extracted the patches archive
dnl
-
AC_MSG_CHECKING(for ptxdist patches)
if test -d `dirname $0`/patches
then
AC_MSG_RESULT(yes)
else
AC_MSG_RESULT(no)
- AC_MSG_ERROR([install the ptxdist-patches archive into the same directory as ptxdist.],[1])
+ AC_MSG_ERROR([install the ptxdist-patches archive into the same directory as ptxdist.])
fi
dnl
dnl Check header files, mostly for lxdialog & kconfig
dnl
-
AC_HEADER_STDC
AC_CHECK_HEADER([regex.h], [], AC_MSG_ERROR([Cannot find regex.h.]))
@@ -38,7 +34,7 @@ AC_SEARCH_LIBS(regcomp, [regex gnuregex],,
CONF_LIBS=${LIBS}
AC_SUBST(CONF_LIBS)
-AC_SEARCH_LIBS(mvaddch, [ncurses curses pdcurses], CURSES_LIB=$ac_lib,
+AC_SEARCH_LIBS(mvaddch, [ncurses curses pdcurses], [CURSES_LIB=$ac_lib],
[AC_MSG_ERROR([ncurses development library not found, please install libncurses-dev])])
MCONF_LIBS=${LIBS}
AC_SUBST(MCONF_LIBS)
@@ -70,8 +66,7 @@ fi
dnl Check for Bourne-Again Shell
unset BASH # bash sets this itself!
-AC_ARG_WITH(bash, AC_HELP_STRING(
- [--with-bash], [name of the bash executable to use]),
+AC_ARG_WITH(bash, AS_HELP_STRING([--with-bash],[name of the bash executable to use]),
[
BASH="$withval"
AC_SUBST(BASH)
@@ -312,8 +307,7 @@ AC_PATH_PROGS(GCC, gcc,, $PATH)
dnl
dnl Checks for python, needed for ipkg-utils
dnl
-AC_ARG_WITH(python, AC_HELP_STRING(
- [--with-python], [name of the python executable to use]),
+AC_ARG_WITH(python, AS_HELP_STRING([--with-python],[name of the python executable to use]),
[
PYTHON="$withval"
AC_SUBST(PYTHON)
@@ -345,8 +339,7 @@ else
fi
dnl Check for patch
-AC_ARG_WITH(patch, AC_HELP_STRING(
- [--with-patch], [name of the patch executable to use]),
+AC_ARG_WITH(patch, AS_HELP_STRING([--with-patch],[name of the patch executable to use]),
[
PATCH="$withval"
AC_SUBST(PATCH)