summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLadislav Michl <ladis@linux-mips.org>2008-01-09 20:59:59 +0000
committerLadislav Michl <ladis@linux-mips.org>2008-01-09 20:59:59 +0000
commitf6a0bd1eada1f346c72443eaaeba031f95f3fa84 (patch)
treec9378602fd7a5c03dcb03bc1af7c0a5045512246 /configure.ac
parent55e552a40ce89525d4adbdec4556394e51e4ea4e (diff)
downloadptxdist-f6a0bd1eada1f346c72443eaaeba031f95f3fa84.tar.gz
ptxdist-f6a0bd1eada1f346c72443eaaeba031f95f3fa84.tar.xz
Check for regex.
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-trunk@7704 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 24389dda8..fe28bad9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,13 +33,18 @@ dnl
AC_HEADER_STDC
-AC_CHECK_LIB([curses], [mvaddch], [CURSES_LIB='curses'])
-AC_CHECK_LIB([ncurses], [mvaddch], [CURSES_LIB='ncurses'])
-AC_CHECK_LIB([pdcurses], [mvaddch], [CURSES_LIB='pdcurses'])
-if test "$CURSES_LIB" = ""
-then
- AC_MSG_ERROR([No curses library found.])
-fi
+AC_CHECK_HEADER([regex.h], [], AC_MSG_ERROR([Cannot find regex.h.]))
+
+AC_SEARCH_LIBS(regcomp, [regex gnuregex],,
+ AC_MSG_ERROR([POSIX regex required.]))
+CONF_LIBS=${LIBS}
+AC_SUBST(CONF_LIBS)
+
+AC_SEARCH_LIBS(mvaddch, [ncurses curses pdcurses], CURSES_LIB=$ac_lib,
+ AC_MSG_ERROR([curses library required.]))
+MCONF_LIBS=${LIBS}
+AC_SUBST(MCONF_LIBS)
+
if test "$CURSES_LIB" = "ncurses"
then
AC_CHECK_HEADER(
@@ -55,7 +60,6 @@ else
)
fi
AC_SUBST(CURSES_LOC)
-AC_SUBST(CURSES_LIB)
AC_SYS_INTERPRETER
if test "$interpval" != yes ; then