summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2006-06-19 22:23:27 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2006-06-19 22:23:27 +0000
commitfe33125239220bc2000721b517a2a589c0d31394 (patch)
treee0a93ac1dfab05908c85bcd67e311161f889b4b9 /configure.ac
parent80e8c87c03244c80c84d4f7fa441e07543013f47 (diff)
downloadptxdist-fe33125239220bc2000721b517a2a589c0d31394.tar.gz
ptxdist-fe33125239220bc2000721b517a2a589c0d31394.tar.xz
* configure.ac, autogen.sh:
added test for pkg-config git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-0.10-trunk@5829 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 5 insertions, 22 deletions
diff --git a/configure.ac b/configure.ac
index bb98ede1d..2a276f8cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,7 +24,12 @@ AC_CHECK_HEADER(
AC_MSG_ERROR([Cannot find ncurses.h. Please install the ncurses development packet.])
)
+AC_PROG_LEX
+AC_PROG_AWK
+AC_PROG_EGREP
AC_PROG_INSTALL
+AC_PROG_YACC
+PKG_PROG_PKG_CONFIG
AC_SYS_INTERPRETER
if test "$interpval" != yes ; then
@@ -135,28 +140,6 @@ else
fi
-dnl
-dnl Check for bison
-dnl
-AC_ARG_WITH(bison, AC_HELP_STRING(
- [--with-bison], [name of the bison executable to use]),
- [
- BISON="$withval"
- AC_SUBST(BISON)
- AC_MSG_NOTICE([Using bison executable $BISON])
- ],[
- BISON="bison"
- AC_SUBST(BISON)
- ])
-AC_MSG_CHECKING(for $BISON)
-if test "`type $BISON 2>&1 > /dev/null && echo yes`" = "yes"; then
- AC_MSG_RESULT(yes)
-else
- AC_MSG_RESULT(no)
- AC_MSG_ERROR(Please install bison.)
-fi
-
-
dnl Check for patch
AC_ARG_WITH(patch, AC_HELP_STRING(
[--with-patch], [name of the patch executable to use]),