summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2010-04-01 21:01:48 +0200
committerMarc Kleine-Budde <mkl@pengutronix.de>2010-04-02 23:12:28 +0200
commitc88c8f5d169e2493ad1fed72204c65043b5e67c2 (patch)
treeca9c08bb9e572415e3cb9c51105084eda76a4e52 /configure.ac
parent67777899db111e0b721b96cff1b53c3d4158e0ee (diff)
downloadptxdist-c88c8f5d169e2493ad1fed72204c65043b5e67c2.tar.gz
ptxdist-c88c8f5d169e2493ad1fed72204c65043b5e67c2.tar.xz
[ptxdist] rework version generation
This patch aims to fix some problems of the version handling of ptxdist which were introducted with switching to timed releases: a) The version is specified in "configure.ac", the "local version" ("00003-gbf29f16") is generated by "setlocalversion". "setlocalversion" generates it's ouput relative to the latest tag. This leads to strange version strings, after creating a tag, and forgetting to run "./autogen.sh && ./configure && make". b) The ptxdist created with a "make dist", even if a not tagged version, always thinks it's a release. c) BSPs working with "master" need a migrate after each release. Because the compatibility checker uses year and month. The problems are^Wshould be fixed with these changes: a) "setlocalversion" now generates the whole full version, e.g.: "2010.04.0-00003-gbf29f16". "configure.ac" uses "m4_esyscmd" to figure out the current version while running "configure". (Yes, "configure"). b) A file ".tarball-version" is added to the tarball to track the version while creating the tarball (same goes for the installation). "setlocalversion" will use the version information from ".tarball-version" c) If both ptxdist and config file are not using a release, i.e. their versions an "appendix", we say it's compatibe, too. Signed-off-by: Marc Kleine-Budde <mkl@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 3 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 76017578a..77b86d729 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4,7 +4,9 @@ dnl Most parts of this configure script have been borrowed from quilt.
dnl
AC_PREREQ(2.59)
-AC_INIT([ptxdist],[2010.04.0],[ptxdist@pengutronix.de])
+AC_INIT([ptxdist],
+ m4_esyscmd([scripts/kernel/setlocalversion .tarball-version]),
+ [ptxdist@pengutronix.de])
AC_CONFIG_AUX_DIR(scripts/autoconf)
AC_CANONICAL_BUILD
AC_CANONICAL_HOST
@@ -403,26 +405,9 @@ AC_ARG_WITH([bash-completion],
)
AC_SUBST(BASH_COMPLETION_DIR)
-dnl
-dnl versions
-dnl
-orig_ifs="${IFS}"
-IFS=.
-set -- ${PACKAGE_VERSION}
-IFS="${orig_ifs}"
-
-PTXDIST_VERSION_YEAR="${1}"
-PTXDIST_VERSION_MONTH="${2}"
-PTXDIST_VERSION_BUGFIX="${3}"
-
-AC_SUBST(PTXDIST_VERSION_YEAR)
-AC_SUBST(PTXDIST_VERSION_MONTH)
-AC_SUBST(PTXDIST_VERSION_BUGFIX)
-
AC_MSG_RESULT([])
AC_CONFIG_FILES( \
Makefile \
- scripts/ptxdist_version.sh \
)
AC_OUTPUT
AC_MSG_RESULT([])