summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Bießmann <andreas@biessmann.de>2014-04-20 09:45:54 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2014-04-21 10:45:30 +0200
commit1e8fc75e31eaf051b4114eafbd7410b5d140ae87 (patch)
treec98eed8b46a2acd439336ef5b972ebf02369a42c /configure.ac
parent52c41c91fc2f9d8b2cd0c4ecfae6322350b2c752 (diff)
downloadptxdist-1e8fc75e31eaf051b4114eafbd7410b5d140ae87.tar.gz
ptxdist-1e8fc75e31eaf051b4114eafbd7410b5d140ae87.tar.xz
configure: search for GNU mktemp
Commit d35a034a99d4bd6053dfe4bd9b1e2169b951430e broke ptxdist on machines with BSD mktemp in $PATH. The introduced -t switch is different in BSD variants and therefore the resulting path is somethink like ---8<--- % mktemp -t -d ptxdist.XXXXXX /var/folders/mp/g80tgyd55bbc9vqjp9zd20600000gp/T/-d.bQehko2k ptxdist.gaZrCM --->8--- which is obviously wrong. Prevent that by providing always the GNU mktemp variant in $PATH. Also remove the now redundant check for installed mktemp. Signed-off-by: Andreas Bießmann <andreas@biessmann.de> Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 1 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 9c3651d31..8d8c9757d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -143,6 +143,7 @@ GNU_TOOL(rm, coreutils)
GNU_TOOL(rmdir, coreutils)
GNU_TOOL(md5sum, coreutils)
GNU_TOOL(mkdir, coreutils)
+GNU_TOOL(mktemp, coreutils)
GNU_TOOL(install, coreutils)
GNU_TOOL(stat, coreutils)
GNU_TOOL(mknod, coreutils)
@@ -241,12 +242,6 @@ if test -z "$UNZIP"; then
AC_MSG_ERROR([unzip could not be found, please install])
fi
-dnl Check for mktemp
-AC_PATH_PROGS(MKTEMP, mktemp,, $PATH)
-if test -z "$MKTEMP"; then
- AC_MSG_ERROR([mktemp could not be found, please install])
-fi
-
dnl Check for wget
AC_PATH_PROGS(WGET, wget,, $PATH)
if test -z "$WGET"; then