summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorRobert Schwebel <r.schwebel@pengutronix.de>2006-03-14 21:18:58 +0000
committerRobert Schwebel <r.schwebel@pengutronix.de>2006-03-14 21:18:58 +0000
commitfc8792c5224ccb9aaf8493bef9d935982d81099b (patch)
treebfb8a9e6a7696ae35c365060c6369d60515aae66 /debian
parentb1ab343ee565d8df6498e8e3871d749aa7071d0c (diff)
downloadptxdist-fc8792c5224ccb9aaf8493bef9d935982d81099b.tar.gz
ptxdist-fc8792c5224ccb9aaf8493bef9d935982d81099b.tar.xz
git-svn-id: https://svn.pengutronix.de/svn/ptxdist/trunks/ptxdist-0.10-trunk@5151 33e552b5-05e3-0310-8538-816dae2090ed
Diffstat (limited to 'debian')
-rw-r--r--debian/control2
-rw-r--r--debian/cron.d.ex4
-rw-r--r--debian/emacsen-install.ex45
-rw-r--r--debian/emacsen-remove.ex15
-rw-r--r--debian/emacsen-startup.ex19
-rw-r--r--debian/init.d.ex74
6 files changed, 1 insertions, 158 deletions
diff --git a/debian/control b/debian/control
index 9a93dc6a0..bbfc8909f 100644
--- a/debian/control
+++ b/debian/control
@@ -2,7 +2,7 @@ Source: ptxdist
Section: devel
Priority: optional
Maintainer: Robert Schwebel <r.schwebel@pengutronix.de>
-Build-Depends: debhelper (>= 4.0.0), autotools-dev
+Build-Depends: debhelper (>= 4.0.0)
Standards-Version: 3.6.2
Package: ptxdist
diff --git a/debian/cron.d.ex b/debian/cron.d.ex
deleted file mode 100644
index 7dc164069..000000000
--- a/debian/cron.d.ex
+++ /dev/null
@@ -1,4 +0,0 @@
-#
-# Regular cron jobs for the ptxdist package
-#
-# 0 4 * * * root ptxdist_maintenance
diff --git a/debian/emacsen-install.ex b/debian/emacsen-install.ex
deleted file mode 100644
index d48ad35b1..000000000
--- a/debian/emacsen-install.ex
+++ /dev/null
@@ -1,45 +0,0 @@
-#! /bin/sh -e
-# /usr/lib/emacsen-common/packages/install/ptxdist
-
-# Written by Jim Van Zandt <jrv@vanzandt.mv.com>, borrowing heavily
-# from the install scripts for gettext by Santiago Vila
-# <sanvila@ctv.es> and octave by Dirk Eddelbuettel <edd@debian.org>.
-
-FLAVOR=$1
-PACKAGE=ptxdist
-
-if [ ${FLAVOR} = emacs ]; then exit 0; fi
-
-echo install/${PACKAGE}: Handling install for emacsen flavor ${FLAVOR}
-
-#FLAVORTEST=`echo $FLAVOR | cut -c-6`
-#if [ ${FLAVORTEST} = xemacs ] ; then
-# SITEFLAG="-no-site-file"
-#else
-# SITEFLAG="--no-site-file"
-#fi
-FLAGS="${SITEFLAG} -q -batch -l path.el -f batch-byte-compile"
-
-ELDIR=/usr/share/emacs/site-lisp/${PACKAGE}
-ELCDIR=/usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-
-# Install-info-altdir does not actually exist.
-# Maybe somebody will write it.
-if test -x /usr/sbin/install-info-altdir; then
- echo install/${PACKAGE}: install Info links for ${FLAVOR}
- install-info-altdir --quiet --section "" "" --dirname=${FLAVOR} /usr/info/${PACKAGE}.info.gz
-fi
-
-install -m 755 -d ${ELCDIR}
-cd ${ELDIR}
-FILES=`echo *.el`
-cp ${FILES} ${ELCDIR}
-cd ${ELCDIR}
-
-cat << EOF > path.el
-(setq load-path (cons "." load-path) byte-compile-warnings nil)
-EOF
-${FLAVOR} ${FLAGS} ${FILES}
-rm -f *.el path.el
-
-exit 0
diff --git a/debian/emacsen-remove.ex b/debian/emacsen-remove.ex
deleted file mode 100644
index d78abd533..000000000
--- a/debian/emacsen-remove.ex
+++ /dev/null
@@ -1,15 +0,0 @@
-#!/bin/sh -e
-# /usr/lib/emacsen-common/packages/remove/ptxdist
-
-FLAVOR=$1
-PACKAGE=ptxdist
-
-if [ ${FLAVOR} != emacs ]; then
- if test -x /usr/sbin/install-info-altdir; then
- echo remove/${PACKAGE}: removing Info links for ${FLAVOR}
- install-info-altdir --quiet --remove --dirname=${FLAVOR} /usr/info/ptxdist.info.gz
- fi
-
- echo remove/${PACKAGE}: purging byte-compiled files for ${FLAVOR}
- rm -rf /usr/share/${FLAVOR}/site-lisp/${PACKAGE}
-fi
diff --git a/debian/emacsen-startup.ex b/debian/emacsen-startup.ex
deleted file mode 100644
index 9d9749037..000000000
--- a/debian/emacsen-startup.ex
+++ /dev/null
@@ -1,19 +0,0 @@
-;; -*-emacs-lisp-*-
-;;
-;; Emacs startup file for the Debian ptxdist package
-;;
-;; Originally contributed by Nils Naumann <naumann@unileoben.ac.at>
-;; Modified by Dirk Eddelbuettel <edd@debian.org>
-;; Adapted for dh-make by Jim Van Zandt <jrv@vanzandt.mv.com>
-
-;; The ptxdist package follows the Debian/GNU Linux 'emacsen' policy and
-;; byte-compiles its elisp files for each 'emacs flavor' (emacs19,
-;; xemacs19, emacs20, xemacs20...). The compiled code is then
-;; installed in a subdirectory of the respective site-lisp directory.
-;; We have to add this to the load-path:
-(let ((package-dir (concat "/usr/share/"
- (symbol-name flavor)
- "/site-lisp/ptxdist")))
- (when (file-directory-p package-dir)
- (setq load-path (cons package-dir load-path))))
-
diff --git a/debian/init.d.ex b/debian/init.d.ex
deleted file mode 100644
index bdd9c65a9..000000000
--- a/debian/init.d.ex
+++ /dev/null
@@ -1,74 +0,0 @@
-#! /bin/sh
-#
-# skeleton example file to build /etc/init.d/ scripts.
-# This file should be used to construct scripts for /etc/init.d.
-#
-# Written by Miquel van Smoorenburg <miquels@cistron.nl>.
-# Modified for Debian
-# by Ian Murdock <imurdock@gnu.ai.mit.edu>.
-#
-# Version: @(#)skeleton 1.9 26-Feb-2001 miquels@cistron.nl
-#
-
-PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
-DAEMON=/usr/sbin/ptxdist
-NAME=ptxdist
-DESC=ptxdist
-
-test -x $DAEMON || exit 0
-
-# Include ptxdist defaults if available
-if [ -f /etc/default/ptxdist ] ; then
- . /etc/default/ptxdist
-fi
-
-set -e
-
-case "$1" in
- start)
- echo -n "Starting $DESC: "
- start-stop-daemon --start --quiet --pidfile /var/run/$NAME.pid \
- --exec $DAEMON -- $DAEMON_OPTS
- echo "$NAME."
- ;;
- stop)
- echo -n "Stopping $DESC: "
- start-stop-daemon --stop --quiet --pidfile /var/run/$NAME.pid \
- --exec $DAEMON
- echo "$NAME."
- ;;
- #reload)
- #
- # If the daemon can reload its config files on the fly
- # for example by sending it SIGHUP, do it here.
- #
- # If the daemon responds to changes in its config file
- # directly anyway, make this a do-nothing entry.
- #
- # echo "Reloading $DESC configuration files."
- # start-stop-daemon --stop --signal 1 --quiet --pidfile \
- # /var/run/$NAME.pid --exec $DAEMON
- #;;
- restart|force-reload)
- #
- # If the "reload" option is implemented, move the "force-reload"
- # option to the "reload" entry above. If not, "force-reload" is
- # just the same as "restart".
- #
- echo -n "Restarting $DESC: "
- start-stop-daemon --stop --quiet --pidfile \
- /var/run/$NAME.pid --exec $DAEMON
- sleep 1
- start-stop-daemon --start --quiet --pidfile \
- /var/run/$NAME.pid --exec $DAEMON -- $DAEMON_OPTS
- echo "$NAME."
- ;;
- *)
- N=/etc/init.d/$NAME
- # echo "Usage: $N {start|stop|restart|reload|force-reload}" >&2
- echo "Usage: $N {start|stop|restart|force-reload}" >&2
- exit 1
- ;;
-esac
-
-exit 0