summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 20 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 5348db8a2..338fb6089 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,11 @@ AC_PROG_CC
AC_PROG_CXX
dnl
+dnl Check for pkg-config
+dnl
+PKG_PROG_PKG_CONFIG
+
+dnl
dnl Check header files, mostly for lxdialog & kconfig
dnl
AC_HEADER_STDC
@@ -41,28 +46,36 @@ AC_SEARCH_LIBS(regcomp, [regex gnuregex],,
CONF_LIBS=${LIBS}
AC_SUBST(CONF_LIBS)
-AC_SEARCH_LIBS(mvaddch, [curses ncurses pdcurses], [CURSES_LIB=$ac_lib],
- [AC_MSG_ERROR([curses development library not found, please install libncurses-dev])])
-MCONF_LIBS=${LIBS}
+PKG_CHECK_MODULES([NCURSES], [ncurses],, [
+ AC_MSG_ERROR([Cannot find ncurses library.])])
+MCONF_LIBS="${LIBS} ${NCURSES_LIBS}"
AC_SUBST(MCONF_LIBS)
+PKG_CHECK_MODULES([NCURSES_PANEL], [panel],,
+ AC_MSG_ERROR([Cannot find ncurses panel library.])])
+PKG_CHECK_MODULES([NCURSES_MENU], [menu],,
+ AC_MSG_ERROR([Cannot find ncurses menu library.])])
+NCONF_LIBS="${LIBS} ${NCURSES_LIBS} ${NCURSES_PANEL_LIBS} ${NCURSES_MENU_LIBS}"
+AC_SUBST(NCONF_LIBS)
+
AC_CHECK_HEADERS(
- [curses.h ncurses.h ncurses/curses.h ncurses/ncurses.h pdcurses.h pdcurses/curses.h pdcurses/pdcurses.h],
+ [curses.h ncurses.h ncurses/curses.h ncurses/ncurses.h],
[CURSES_LOC="<$ac_header>";found_curses_headers=yes; break;])
AS_IF([test "x$CURSES_LOC" = "x"],
- [AC_MSG_ERROR([curses headers not found])])
+ [AC_MSG_ERROR([ncurses headers not found])])
AC_SUBST(CURSES_LOC)
+CPPFLAGS="${NCURSES_CFLAGS}"
AC_ARG_WITH(ncurses, AS_HELP_STRING([--with-ncurses],[Include path to the ncurses headers]),
[
if test "x$withval" != "xyes"; then
- CPPFLAGS="-I$withval"
- AC_SUBST(CPPFLAGS)
+ CPPFLAGS="-I$withval ${CPPFLAGS}"
fi
with_ncurses=yes
],[
with_ncurses=auto
])
+AC_SUBST(CPPFLAGS)
AC_CHECK_HEADER(
[menu.h],