summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e539f87db..640974a42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -279,6 +279,15 @@ if test -z "$MSGFMT"; then
AC_MSG_ERROR([gettext could not be found, please install])
fi
+AC_PATH_PROG(SPHINX, sphinx-build,, $PATH)
+if test -z "$SPHINX"; then
+ AC_MSG_NOTICE([sphinx not found, required to build the documentation])
+ SPHINX=sphinx-build
+else
+ AC_MSG_NOTICE([sphinx found, run 'make docs' to get documentation])
+fi
+AC_SUBST(SPHINX)
+
dnl
dnl Checks for Python, needed for ipkg-utils
dnl