summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMarc Kleine-Budde <mkl@pengutronix.de>2005-04-06 15:33:36 +0000
committerMarc Kleine-Budde <mkl@pengutronix.de>2005-04-06 15:33:36 +0000
commitb0b16e08bc7d55177299e28721735130d687c318 (patch)
tree0adf5d573fb9cac4d970bc6dae0c9f6fa592d3df /configure.ac
parent89701ce911a2030b0437708484e2d9abe7377acb (diff)
downloadcanutils-b0b16e08bc7d55177299e28721735130d687c318.tar.gz
canutils-b0b16e08bc7d55177299e28721735130d687c318.tar.xz
cleanups, install now can.h
git-svn-id: https://iocaste.extern.pengutronix.de/svn/canutils/trunks/canutils-1.0-trunks@15 5fd5a299-6ef2-0310-aa18-8b01d7c39d8c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 21 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a16a828..93b1aaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,17 +1,29 @@
+# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.57)
-AC_INIT(canutils, 1.0.0, r.schwebel@pengutronix.de)
-AM_INIT_AUTOMAKE
+AC_PREREQ(2.59)
+AC_INIT([canutils], [1.0.1], [socket-can@@pengutronix.de])
+AC_CONFIG_HEADERS([include/can_config.h])
+AC_CONFIG_AUX_DIR([config/autoconf])
+AC_CONFIG_MACRO_DIR([config/m4])
AC_CONFIG_SRCDIR([cansend.c])
-
-#AC_CONFIG_HEADER([can.h])
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+AC_PROG_INSTALL
# Checks for programs.
AC_PROG_CC
AC_PROG_LIBTOOL
+AM_INIT_AUTOMAKE([foreign no-exeext dist-bzip2])
+AM_MAINTAINER_MODE
+AC_PROG_LIBTOOL
+AM_PROG_AS
+AC_SUBST(LD)
+AM_INIT_AUTOMAKE
+
+
# Checks for libraries.
# Checks for header files.
@@ -22,5 +34,8 @@ AC_CHECK_HEADERS([stdlib.h string.h])
AC_TYPE_SIZE_T
# Checks for library functions.
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([ \
+ Makefile \
+ include/Makefile \
+ ])
AC_OUTPUT