summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 33724ec..34663d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,7 +2,14 @@
# Binary programs
#
-bin_PROGRAMS = candump canecho cansend canconfig
+bin_PROGRAMS = candump canecho cansend
+sbin_PROGRAMS = canconfig
+
+SUBDIRS = include
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include
+ -I$(top_builddir)/include
candump_SOURCES = candump.c
canecho_SOURCES = canecho.c
@@ -16,12 +23,12 @@ man_MANS = canconfig.8 candump.8 canecho.8 cansend.8
# info_TEXINFOS = can.texinfo
MAINTAINERCLEANFILES= \
+ include/can_config.h.in \
configure \
Makefile.in \
config.guess \
config.sub \
ltmain.sh \
- .Makefile.am.swp \
aclocal.m4