summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 21 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index a16a828..93b1aaf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,17 +1,29 @@
+# -*- Autoconf -*-
# Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.57)
-AC_INIT(canutils, 1.0.0, r.schwebel@pengutronix.de)
-AM_INIT_AUTOMAKE
+AC_PREREQ(2.59)
+AC_INIT([canutils], [1.0.1], [socket-can@@pengutronix.de])
+AC_CONFIG_HEADERS([include/can_config.h])
+AC_CONFIG_AUX_DIR([config/autoconf])
+AC_CONFIG_MACRO_DIR([config/m4])
AC_CONFIG_SRCDIR([cansend.c])
-
-#AC_CONFIG_HEADER([can.h])
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+AC_PROG_INSTALL
# Checks for programs.
AC_PROG_CC
AC_PROG_LIBTOOL
+AM_INIT_AUTOMAKE([foreign no-exeext dist-bzip2])
+AM_MAINTAINER_MODE
+AC_PROG_LIBTOOL
+AM_PROG_AS
+AC_SUBST(LD)
+AM_INIT_AUTOMAKE
+
+
# Checks for libraries.
# Checks for header files.
@@ -22,5 +34,8 @@ AC_CHECK_HEADERS([stdlib.h string.h])
AC_TYPE_SIZE_T
# Checks for library functions.
-AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([ \
+ Makefile \
+ include/Makefile \
+ ])
AC_OUTPUT