summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSascha Hauer <s.hauer@pengutronix.de>2013-11-13 15:00:57 +0100
committerSascha Hauer <s.hauer@pengutronix.de>2014-01-27 11:52:06 +0100
commit136ce91fb5d9194546bfcf49ac87a614a3a458c5 (patch)
treeb243649344d993e48469f77fd6eace4a4d9f56da /configure.ac
parent6c37a935b85774f56871a75f2069c8041068d34c (diff)
downloaddt-utils-136ce91fb5d9194546bfcf49ac87a614a3a458c5.tar.gz
dt-utils-136ce91fb5d9194546bfcf49ac87a614a3a458c5.tar.xz
2nd commitv0.2.0
Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac68
1 files changed, 68 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..f1d4bbe
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,68 @@
+AC_PREREQ(2.60)
+AC_INIT([dt],
+ [4],
+ [s.hauer@pengutronix.de],
+ [dt],
+ [http://www.pengutronix.de/dt/])
+AC_CONFIG_SRCDIR([src/libdt.c])
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([check-news foreign 1.11 -Wall -Wno-portability silent-rules tar-pax no-dist-gzip dist-xz subdir-objects])
+AC_PROG_CC_STDC
+AC_USE_SYSTEM_EXTENSIONS
+AC_SYS_LARGEFILE
+AC_CONFIG_MACRO_DIR([m4])
+AM_SILENT_RULES([yes])
+LT_INIT([disable-static pic-only])
+AC_PREFIX_DEFAULT([/usr])
+
+AC_PROG_SED
+AC_PROG_MKDIR_P
+
+AC_ARG_ENABLE([logging],
+ AS_HELP_STRING([--disable-logging], [disable system logging @<:@default=enabled@:>@]),
+ [], enable_logging=yes)
+AS_IF([test "x$enable_logging" = "xyes"], [
+ AC_DEFINE(ENABLE_LOGGING, [1], [System logging.])
+])
+
+AC_ARG_ENABLE([debug],
+ AS_HELP_STRING([--enable-debug], [enable debug messages @<:@default=disabled@:>@]),
+ [], [enable_debug=no])
+AS_IF([test "x$enable_debug" = "xyes"], [
+ AC_DEFINE(ENABLE_DEBUG, [1], [Debug messages.])
+])
+
+AC_CHECK_FUNCS([__secure_getenv secure_getenv])
+
+my_CFLAGS="-Wall \
+-Wmissing-declarations -Wmissing-prototypes \
+-Wnested-externs -Wpointer-arith \
+-Wpointer-arith -Wsign-compare -Wchar-subscripts \
+-Wstrict-prototypes -Wshadow \
+-Wformat-security -Wtype-limits"
+AC_SUBST([my_CFLAGS])
+
+PKG_CHECK_MODULES(UDEV, [libudev])
+
+AC_CONFIG_HEADERS(config.h)
+AC_CONFIG_FILES([
+ Makefile
+])
+
+AC_OUTPUT
+AC_MSG_RESULT([
+ $PACKAGE $VERSION
+ =====
+
+ prefix: ${prefix}
+ sysconfdir: ${sysconfdir}
+ libdir: ${libdir}
+ includedir: ${includedir}
+
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ ldflags: ${LDFLAGS}
+
+ logging: ${enable_logging}
+ debug: ${enable_debug}
+])