summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 25 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3de789d..a32517f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -2,6 +2,30 @@ EXTRA_DIST = README.devel
bin_PROGRAMS = memtool
-memtool_SOURCES = memtool.c
+noinst_HEADERS = fileaccess.h fileaccpriv.h
+memtool_SOURCES = memtool.c fileaccess.c acc_mmap.c
+if MDIO
+memtool_SOURCES += acc_mdio.c
+endif
dist_man_MANS = memtool.1
+
+# clean files "make" has built
+CLEANFILES = \
+ $(DIST_ARCHIVES)
+
+# clean files "configure" has built
+DISTCLEAN = \
+ config.log \
+ config.status \
+ Makefile
+
+# clean all files the maintainer of the package has created
+MAINTAINERCLEANFILES = \
+ compile \
+ Makefile.in \
+ configure \
+ depcomp \
+ install-sh \
+ missing \
+ aclocal.m4