summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2019-09-03 10:28:59 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2019-09-03 15:15:31 +0200
commitc111e1f9d381774b3255e6d8ad5ca2cd7f85d70f (patch)
tree81ff594c3375a57cee3d555469f9b08682956242 /debian
parent094c9f77f4e39472b0266a905237e7cdbeafa599 (diff)
downloadOSELAS.Toolchain-c111e1f9d381774b3255e6d8ad5ca2cd7f85d70f.tar.gz
OSELAS.Toolchain-c111e1f9d381774b3255e6d8ad5ca2cd7f85d70f.tar.xz
remove special DESTDIR handling
Use the regular <platform>/sysroot-cross instead. The toolchain is relocatable. Building it in /opt is not necessary and it is currently broken anyways. Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore1
-rwxr-xr-xdebian/rules15
2 files changed, 9 insertions, 7 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index 37cdd01..8d72c14 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -8,3 +8,4 @@
/oselas.toolchain-20*-*.substvars
/oselas.toolchain-20*/
/ptxdistrc
+/excludes
diff --git a/debian/rules b/debian/rules
index b792bb1..d08735b 100755
--- a/debian/rules
+++ b/debian/rules
@@ -28,18 +28,19 @@ override_dh_auto_build: debian/ptxdistrc
$(PTXDIST_ENV) make -f build_all_v2.mk ARG="-j -q go" PTXDIST="$(PTXDIST)" $(TOOLCHAINS)
override_dh_auto_install-arch:
- mkdir -p $(CURDIR)/debian/tmp
rm -rf $(CURDIR)/debian/tmp/opt
- cp -a inst/opt $(CURDIR)/debian/tmp/
+ mkdir -p $(CURDIR)/debian/tmp/opt
+ cp -a platform-*/sysroot-cross/opt/* $(CURDIR)/debian/tmp/opt/
+ echo -Xsysroot- > $(CURDIR)/debian/excludes
+ ls -d $(CURDIR)/debian/tmp/opt/OSELAS.Toolchain-*/*/*/*/lib \
+ $(CURDIR)/debian/tmp/opt/OSELAS.Toolchain-*/*/*/lib/gcc/*/* \
+ | sed 's;$(CURDIR)/debian/tmp;-X;' >> $(CURDIR)/debian/excludes
override_dh_auto_clean:
dh_auto_clean
- rm -rf gstate platform-* inst/
+ rm -rf gstate platform-*
-EXCLUDES = \
- -Xsysroot- \
- $(foreach d,$(wildcard inst/opt/OSELAS.Toolchain-*/*/*/*/lib),-X$(subst inst,,$(d))) \
- $(foreach d,$(wildcard inst/opt/OSELAS.Toolchain-*/*/*/lib/gcc/*/*),-X$(subst inst,,$(d)))
+EXCLUDES = $(shell cat $(CURDIR)/debian/excludes)
# don't change the permissions of target files
# the dynamic linker and glibc must remain executable