summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoland Hieber <rhi@pengutronix.de>2020-08-23 22:38:23 +0200
committerRoland Hieber <rhi@pengutronix.de>2020-08-23 23:20:29 +0200
commit1631f1149e4924554ae924a81a70e63e1e5447b4 (patch)
tree4850b3ff5f676609148bc90acd4cc4386747ee5f
parent2e6535c27d6a7518e3e9ab9f6b60abe6c9e963bc (diff)
downloadbarebox-1631f1149e4924554ae924a81a70e63e1e5447b4.tar.gz
barebox-1631f1149e4924554ae924a81a70e63e1e5447b4.tar.xz
debian: remove old patches, all were applied in v2018.07.0
-rw-r--r--debian/patches/0001-imx-usb-loader-Align-uploaded-file-length.patch46
-rw-r--r--debian/patches/0002-imx-usb-loader-Fix-verify-for-non-word-aligned-lengt.patch36
-rw-r--r--debian/patches/0003-imx-usb-loader-dump-memory-bytewise-on-verification-.patch61
-rw-r--r--debian/patches/0004-scripts-create-a-separate-section-for-host-tools.patch161
-rw-r--r--debian/patches/0005-scripts-omap3-usb-loader-fix-compiler-warning.patch38
-rw-r--r--debian/patches/series5
6 files changed, 0 insertions, 347 deletions
diff --git a/debian/patches/0001-imx-usb-loader-Align-uploaded-file-length.patch b/debian/patches/0001-imx-usb-loader-Align-uploaded-file-length.patch
deleted file mode 100644
index 086b2091f5..0000000000
--- a/debian/patches/0001-imx-usb-loader-Align-uploaded-file-length.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From: Sascha Hauer <s.hauer@pengutronix.de>
-Date: Thu, 24 May 2018 11:59:02 +0200
-Subject: imx-usb-loader: Align uploaded file length
-
-At least i.MX25 does not properly upload a non word aligned file length.
-Align the uploaded length to word length to make sure the end of the
-file is also transferred properly.
-
-Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
-Origin: https://git.pengutronix.de/cgit/barebox/commit/?h=next&id=b28e0798c0
-Applied-Upstream: v2018.07.0, commit:b28e0798c0be2bdebd7f3d8f4dd1020866e759a9
----
- scripts/imx/imx-usb-loader.c | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/scripts/imx/imx-usb-loader.c b/scripts/imx/imx-usb-loader.c
-index 43dde8b..cbb17cb 100644
---- a/scripts/imx/imx-usb-loader.c
-+++ b/scripts/imx/imx-usb-loader.c
-@@ -40,6 +40,8 @@
-
- #define get_min(a, b) (((a) < (b)) ? (a) : (b))
-
-+#define ALIGN(x, a) (((x) + (a) - 1) & ~((a) - 1))
-+
- #define FT_APP 0xaa
- #define FT_CSF 0xcc
- #define FT_DCD 0xee
-@@ -412,7 +414,7 @@ static int read_file(const char *name, unsigned char **buffer, unsigned *size)
- return -2;
- }
-
-- buf = malloc(fsize);
-+ buf = malloc(ALIGN(fsize, 4));
- if (!buf) {
- printf("error, out of memory\n");
- fclose(xfile);
-@@ -762,6 +764,8 @@ static int load_file(void *buf, unsigned len, unsigned dladdr, unsigned char typ
- void *p;
- int cnt;
-
-+ len = ALIGN(len, 4);
-+
- dl_command.addr = htonl(dladdr);
- dl_command.cnt = htonl(len);
- dl_command.rsvd = type;
diff --git a/debian/patches/0002-imx-usb-loader-Fix-verify-for-non-word-aligned-lengt.patch b/debian/patches/0002-imx-usb-loader-Fix-verify-for-non-word-aligned-lengt.patch
deleted file mode 100644
index 0b3b8717d3..0000000000
--- a/debian/patches/0002-imx-usb-loader-Fix-verify-for-non-word-aligned-lengt.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From: Sascha Hauer <s.hauer@pengutronix.de>
-Date: Thu, 24 May 2018 07:21:12 +0200
-Subject: imx-usb-loader: Fix verify for non word aligned lengths
-
-Verifying the uploaded image fails when the length is not word aligned.
-This is because read_memory reads full words, so the input length must
-be word aligned. Align the length up to 4 bytes so that we do not pass
-unaligned lengths to read_memory.
-
-Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
-Origin: https://git.pengutronix.de/cgit/barebox/commit/?h=next&id=56d1e82d77
-Applied-Upstream: v2018.07.0, commit:56d1e82d77c5e7269e91dc2b1dbc63c0a15bb6db
----
- scripts/imx/imx-usb-loader.c | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/scripts/imx/imx-usb-loader.c b/scripts/imx/imx-usb-loader.c
-index cbb17cb..7e0a110 100644
---- a/scripts/imx/imx-usb-loader.c
-+++ b/scripts/imx/imx-usb-loader.c
-@@ -1164,12 +1164,13 @@ static int verify_memory(const void *buf, unsigned len, unsigned addr)
- int ret, mismatch = 0;
- void *readbuf;
- unsigned offset = 0, now;
-+ unsigned alen = ALIGN(len, 4);
-
-- readbuf = malloc(len);
-+ readbuf = malloc(alen);
- if (!readbuf)
- return -ENOMEM;
-
-- ret = read_memory(addr, readbuf, len);
-+ ret = read_memory(addr, readbuf, alen);
- if (ret < 0)
- goto err;
-
diff --git a/debian/patches/0003-imx-usb-loader-dump-memory-bytewise-on-verification-.patch b/debian/patches/0003-imx-usb-loader-dump-memory-bytewise-on-verification-.patch
deleted file mode 100644
index ec5716067c..0000000000
--- a/debian/patches/0003-imx-usb-loader-dump-memory-bytewise-on-verification-.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-From: Sascha Hauer <s.hauer@pengutronix.de>
-Date: Thu, 24 May 2018 07:31:18 +0200
-Subject: imx-usb-loader: dump memory bytewise on verification mismatch
-
-dump_long only prints the full words and does not print the unaligned
-rest. This means that some bytes (and maybe actually the interesting
-ones) may not be printed. Use dump_bytes instead which does not have
-this problem.
-
-Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
-Origin: https://git.pengutronix.de/cgit/barebox/commit/?h=next&id=ca929ac265
-Applied-Upstream: v2018.07.0, commit:ca929ac265bd7560b82e7b0c5ce4521ac658b768
----
- scripts/imx/imx-usb-loader.c | 26 ++------------------------
- 1 file changed, 2 insertions(+), 24 deletions(-)
-
-diff --git a/scripts/imx/imx-usb-loader.c b/scripts/imx/imx-usb-loader.c
-index 7e0a110..541c59e 100644
---- a/scripts/imx/imx-usb-loader.c
-+++ b/scripts/imx/imx-usb-loader.c
-@@ -331,28 +331,6 @@ static libusb_device *find_imx_dev(libusb_device **devs, const struct mach_id **
- return NULL;
- }
-
--static void dump_long(const void *src, unsigned cnt, unsigned addr)
--{
-- const unsigned *p = (unsigned *)src;
--
-- while (cnt >= 32) {
-- printf("%08x: %08x %08x %08x %08x %08x %08x %08x %08x\n",
-- addr, p[0], p[1], p[2], p[3], p[4], p[5], p[6], p[7]);
-- p += 8;
-- cnt -= 32;
-- addr += 32;
-- }
-- if (cnt) {
-- printf("%08x:", addr);
-- while (cnt >= 4) {
-- printf(" %08x", p[0]);
-- p++;
-- cnt -= 4;
-- }
-- printf("\n");
-- }
--}
--
- static void dump_bytes(const void *src, unsigned cnt, unsigned addr)
- {
- const unsigned char *p = src;
-@@ -1179,9 +1157,9 @@ static int verify_memory(const void *buf, unsigned len, unsigned addr)
-
- if (memcmp(buf + offset, readbuf + offset, now)) {
- printf("mismatch at offset 0x%08x. expected:\n", offset);
-- dump_long(buf + offset, now, addr + offset);
-+ dump_bytes(buf + offset, now, addr + offset);
- printf("read:\n");
-- dump_long(readbuf + offset, now, addr + offset);
-+ dump_bytes(readbuf + offset, now, addr + offset);
- ret = -EINVAL;
- mismatch++;
- if (mismatch > 4)
diff --git a/debian/patches/0004-scripts-create-a-separate-section-for-host-tools.patch b/debian/patches/0004-scripts-create-a-separate-section-for-host-tools.patch
deleted file mode 100644
index 48ebee4871..0000000000
--- a/debian/patches/0004-scripts-create-a-separate-section-for-host-tools.patch
+++ /dev/null
@@ -1,161 +0,0 @@
-From: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
-Date: Sat, 9 Jun 2018 09:27:56 +0200
-Subject: scripts: create a separate section for host tools
-
-This allows to enable host tools even if they are not needed for the
-current configuration to improve compile coverage and simplify packaging
-these tools. The conversion doesn't cover all tools available but can be
-extended later.
-
-Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
-Origin: https://git.pengutronix.de/cgit/barebox/commit/?h=next&id=526dddf4c3
-Applied-Upstream: v2018.07.0, commit:526dddf4c3493a7b7732d9bd0aab2d3e22b3154a
----
- Kconfig | 2 ++
- arch/arm/Kconfig | 1 -
- arch/arm/mach-omap/Kconfig | 6 ------
- scripts/Kconfig | 51 ++++++++++++++++++++++++++++++++++++++++++++++
- scripts/Makefile | 6 +++---
- scripts/imx/Kconfig | 4 ++--
- 6 files changed, 58 insertions(+), 12 deletions(-)
- create mode 100644 scripts/Kconfig
-
-diff --git a/Kconfig b/Kconfig
-index 53d4f5a..197dd1c 100644
---- a/Kconfig
-+++ b/Kconfig
-@@ -9,3 +9,5 @@ config SRCARCH
- option env="SRCARCH"
-
- source "arch/$SRCARCH/Kconfig"
-+
-+source "scripts/Kconfig"
-diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
-index 37cde0c..c1a89e1 100644
---- a/arch/arm/Kconfig
-+++ b/arch/arm/Kconfig
-@@ -265,7 +265,6 @@ source arch/arm/mach-ep93xx/Kconfig
- source arch/arm/mach-highbank/Kconfig
- source arch/arm/mach-imx/Kconfig
- source arch/arm/mach-mxs/Kconfig
--source scripts/imx/Kconfig
- source arch/arm/mach-mvebu/Kconfig
- source arch/arm/mach-netx/Kconfig
- source arch/arm/mach-nomadik/Kconfig
-diff --git a/arch/arm/mach-omap/Kconfig b/arch/arm/mach-omap/Kconfig
-index e8fc4b8..c451cf0 100644
---- a/arch/arm/mach-omap/Kconfig
-+++ b/arch/arm/mach-omap/Kconfig
-@@ -138,12 +138,6 @@ config OMAP3_USBBOOT
- which is already initialized by the ROM code. Use the omap3-usb-loader
- tool selectable below to upload images.
-
--config OMAP3_USB_LOADER
-- bool "enable omap3 USB loader host tool"
-- depends on ARCH_OMAP3
-- help
-- Say Y here to build the omap3 usb loader tool.
--
- config OMAP_SERIALBOOT
- bool "enable booting from serial"
- select XYMODEM
-diff --git a/scripts/Kconfig b/scripts/Kconfig
-new file mode 100644
-index 0000000..14a577a
---- /dev/null
-+++ b/scripts/Kconfig
-@@ -0,0 +1,51 @@
-+menu "Host Tools"
-+
-+config COMPILE_HOST_TOOLS
-+ bool "Allow to enable unused host tools"
-+ help
-+ Usually the needed host tools are selected (or selectable) depending
-+ on some config options. If you say yes here, the host tools that are
-+ not needed can be selected, too.
-+
-+ This is usefull for compile coverage testing and for packaging the
-+ host tools.
-+
-+source scripts/imx/Kconfig
-+
-+config MVEBU_HOSTTOOLS
-+ bool "mvebu hosttools" if COMPILE_HOST_TOOLS
-+ depends on ARCH_MVEBU || COMPILE_HOST_TOOLS
-+ default y if ARCH_MVEBU
-+ help
-+ This enables building the tools kwbimage to create an image suitable
-+ for Marvell mvebu machines and kwboot to boot via UART.
-+
-+config MXS_HOSTTOOLS
-+ bool "mxs hosttools" if COMPILE_HOST_TOOLS
-+ depends on ARCH_MXS || COMPILE_HOST_TOOLS
-+ default y if ARCH_MXS
-+ help
-+ This builds the tools mxsimage and mxsboot which are needed to
-+ create bootable image files for mxs. You need openssl development
-+ files to compile this tool.
-+
-+config OMAP3_USB_LOADER
-+ bool "omap3 USB loader"
-+ depends on ARCH_OMAP3 || COMPILE_HOST_TOOLS
-+ help
-+ Say Y here to build the omap3 usb loader tool.
-+
-+ You need libusb-1.0 to compile this tool.
-+
-+config OMAP4_HOSTTOOL_USBBOOT
-+ bool "omap4 usbboot"
-+ depends on (ARCH_OMAP4 && !MMU) || COMPILE_HOST_TOOLS
-+ default y if OMAP4_USBBOOT
-+ help
-+ Say Y here to build the omap4 usb loader tool.
-+ Note that you need to enable OMAP4_USBBOOT to create an image
-+ suitable to boot using this tool.
-+
-+ You need libusb-1.0 to compile this tool.
-+
-+endmenu
-diff --git a/scripts/Makefile b/scripts/Makefile
-index 8eda41e..59d22e1 100644
---- a/scripts/Makefile
-+++ b/scripts/Makefile
-@@ -12,14 +12,14 @@ hostprogs-y += bareboxcrc32
- hostprogs-y += kernel-install
- hostprogs-$(CONFIG_IMD) += bareboximd
- hostprogs-$(CONFIG_KALLSYMS) += kallsyms
--hostprogs-$(CONFIG_ARCH_MVEBU) += kwbimage kwboot
-+hostprogs-$(CONFIG_MVEBU_HOSTTOOLS) += kwbimage kwboot
- hostprogs-$(CONFIG_ARCH_NETX) += gen_netx_image
- hostprogs-$(CONFIG_ARCH_OMAP) += omap_signGP mk-omap-image
- hostprogs-$(CONFIG_ARCH_S5PCxx) += s5p_cksum
- hostprogs-$(CONFIG_ARCH_DAVINCI) += mkublheader
- hostprogs-$(CONFIG_ARCH_ZYNQ) += zynq_mkimage
- hostprogs-$(CONFIG_ARCH_SOCFPGA) += socfpga_mkimage
--hostprogs-$(CONFIG_ARCH_MXS) += mxsimage mxsboot
-+hostprogs-$(CONFIG_MXS_HOSTTOOLS)+= mxsimage mxsboot
- HOSTCFLAGS += -I$(srctree)/scripts/include/
- HOSTLOADLIBES_mxsimage = `pkg-config --libs openssl`
- HOSTCFLAGS_omap3-usb-loader.o = `pkg-config --cflags libusb-1.0`
-@@ -27,7 +27,7 @@ HOSTLOADLIBES_omap3-usb-loader = `pkg-config --libs libusb-1.0`
- hostprogs-$(CONFIG_OMAP3_USB_LOADER) += omap3-usb-loader
- HOSTCFLAGS_omap4_usbboot.o = `pkg-config --cflags libusb-1.0`
- HOSTLOADLIBES_omap4_usbboot = -lpthread `pkg-config --libs libusb-1.0`
--hostprogs-$(CONFIG_OMAP4_USBBOOT) += omap4_usbboot
-+hostprogs-$(CONFIG_OMAP4_HOSTTOOL_USBBOOT) += omap4_usbboot
-
- subdir-y += mod
- subdir-y += imx
-diff --git a/scripts/imx/Kconfig b/scripts/imx/Kconfig
-index fda9c63..ef83fa1 100644
---- a/scripts/imx/Kconfig
-+++ b/scripts/imx/Kconfig
-@@ -1,6 +1,6 @@
- config ARCH_IMX_USBLOADER
-- depends on ARCH_MXS || ARCH_IMX
-- bool "compile imx-usb-loader"
-+ depends on ARCH_MXS || ARCH_IMX || COMPILE_HOST_TOOLS
-+ bool "imx-usb-loader"
- help
- imx-usb-loader is a tool to upload and start imximages to an i.MX SoC
- in ROM boot mode. It requires libusb, so make sure you have the libusb
diff --git a/debian/patches/0005-scripts-omap3-usb-loader-fix-compiler-warning.patch b/debian/patches/0005-scripts-omap3-usb-loader-fix-compiler-warning.patch
deleted file mode 100644
index 419ccf89c5..0000000000
--- a/debian/patches/0005-scripts-omap3-usb-loader-fix-compiler-warning.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From: Sascha Hauer <s.hauer@pengutronix.de>
-Date: Mon, 11 Jun 2018 09:06:28 +0200
-Subject: scripts: omap3-usb-loader: fix compiler warning
-
-Compiling omap3-usb-loader issues the warning:
-
-warning: self-comparison always evaluates to true [-Wtautological-compare]
-
-Just remove the bogus test.
-
-Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
-Origin: https://git.pengutronix.de/cgit/barebox/commit/?h=next&id=23ee83f42f
-Applied-Upstream: v2018.07.0, commit:23ee83f42f947a7f9d725c71f638f7c9bacc93c3
----
- scripts/omap3-usb-loader.c | 10 ++++------
- 1 file changed, 4 insertions(+), 6 deletions(-)
-
-diff --git a/scripts/omap3-usb-loader.c b/scripts/omap3-usb-loader.c
-index edf6043..3ba9af0 100644
---- a/scripts/omap3-usb-loader.c
-+++ b/scripts/omap3-usb-loader.c
-@@ -354,12 +354,10 @@ static unsigned char *read_file(char *path, size_t *readamt)
- size_t iter = 0;
-
- while (1) {
-- if (iter >= iter) {
-- allocsize += 1024;
-- data = realloc(data, allocsize);
-- if (!data)
-- return NULL;
-- }
-+ allocsize += 1024;
-+ data = realloc(data, allocsize);
-+ if (!data)
-+ return NULL;
-
- size_t readsize = allocsize - iter;
- size_t ret = fread(data + iter, sizeof (unsigned char), readsize, fp);
diff --git a/debian/patches/series b/debian/patches/series
deleted file mode 100644
index ea608c44c2..0000000000
--- a/debian/patches/series
+++ /dev/null
@@ -1,5 +0,0 @@
-0001-imx-usb-loader-Align-uploaded-file-length.patch
-0002-imx-usb-loader-Fix-verify-for-non-word-aligned-lengt.patch
-0003-imx-usb-loader-dump-memory-bytewise-on-verification-.patch
-0004-scripts-create-a-separate-section-for-host-tools.patch
-0005-scripts-omap3-usb-loader-fix-compiler-warning.patch