summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorSascha Hauer <s.hauer@pengutronix.de>2023-08-03 08:57:49 +0200
committerSascha Hauer <s.hauer@pengutronix.de>2023-08-03 15:27:12 +0200
commitb81564274cd8c645ecaa11c06f97b0c6ad6bbf8a (patch)
tree5f98623bb3f6b0e21aea552565309877d72884b6 /Makefile
parentaf084cae41ceb530728857e248700eb240c97230 (diff)
downloadbarebox-b81564274cd8c645ecaa11c06f97b0c6ad6bbf8a.tar.gz
barebox-b81564274cd8c645ecaa11c06f97b0c6ad6bbf8a.tar.xz
Drop mkimage tool
The barebox sourcetree contains a very outdated U-Boot mkimage tool. The only purpose of this tool is to create a uImage barebox image which can be used to start barebox 2nd stage from U-Boot. There is also a Make target for generating such an image. This however predates PBL support and is incompatible with PBL enabled barebox builds. As the barebox.uimage target is not very useful nowadays remove it. A recent mkimage is availabe in most Linux distributions as a host tool, so remove the outdated version from barebox as well. Link: https://lore.barebox.org/20230803065749.3827198-1-s.hauer@pengutronix.de Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile16
1 files changed, 0 insertions, 16 deletions
diff --git a/Makefile b/Makefile
index c9d8311357..1efe90f41c 100644
--- a/Makefile
+++ b/Makefile
@@ -940,22 +940,6 @@ endif
PHONY += install
-# By default the uImage load address is 2MB below CONFIG_TEXT_BASE,
-# leaving space for the compressed PBL image at 1MB below CONFIG_TEXT_BASE.
-UIMAGE_BASE ?= $(shell printf "0x%08x" $$(($(CONFIG_TEXT_BASE) - 0x200000)))
-
-# For development provide a target which makes barebox loadable by an
-# unmodified u-boot
-quiet_cmd_barebox_mkimage = MKIMAGE $@
- cmd_barebox_mkimage = $(srctree)/scripts/mkimage -A $(SRCARCH) -T firmware -C none \
- -O barebox -a $(UIMAGE_BASE) -e $(UIMAGE_BASE) \
- -n "barebox $(KERNELRELEASE)" -d $< $@
-
-# barebox.uimage is build from the raw barebox binary, without any other
-# headers.
-barebox.uimage: $(KBUILD_BINARY) FORCE
- $(call if_changed,barebox_mkimage)
-
# barebox image
barebox: $(BAREBOX_LDS) $(BAREBOX_OBJS) $(kallsyms.o) FORCE
$(call if_changed_rule,barebox__)