summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorAhmad Fatoum <a.fatoum@pengutronix.de>2023-08-07 09:44:45 +0200
committerSascha Hauer <s.hauer@pengutronix.de>2023-08-18 07:37:45 +0200
commit1fcb64972029a2624a4e4c47a60eed3aaf5355bb (patch)
treec009c7bdad3e6e31f02189f19fb161e1df17d069 /scripts
parenta22de4719dbf992e0ba41f798eed0805d0a40e61 (diff)
downloadbarebox-1fcb64972029a2624a4e4c47a60eed3aaf5355bb.tar.gz
barebox-1fcb64972029a2624a4e4c47a60eed3aaf5355bb.tar.xz
ARM: i.MX25: image: consult pkg-config for openssl cflags
For i.MX HABv3, we already ask pkg-config about the flags to link the image generation utility against OpenSSL, but we assumed that the headers would be found in the toolchain's default system header search path. This may not always be the case, so explicitly ask pkg-config about the CFLAGS as well. Signed-off-by: Ahmad Fatoum <a.fatoum@pengutronix.de> Link: https://lore.barebox.org/20230807074445.1042385-1-a.fatoum@pengutronix.de Signed-off-by: Sascha Hauer <s.hauer@pengutronix.de>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/imx/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/imx/Makefile b/scripts/imx/Makefile
index 9544974d52..739641b477 100644
--- a/scripts/imx/Makefile
+++ b/scripts/imx/Makefile
@@ -15,7 +15,7 @@ HOSTCFLAGS_imx-image.o = -I$(srctree) -I$(srctree)/include/mach
HOSTCFLAGS_imx-usb-loader.o += -I$(srctree) -I$(srctree)/include/mach
imx-usb-loader-target-userccflags += -I$(srctree) -I$(srctree)/include/mach
ifdef CONFIG_ARCH_IMX_IMXIMAGE_SSL_SUPPORT
-HOSTCFLAGS_imx-image.o += -DIMXIMAGE_SSL_SUPPORT
+HOSTCFLAGS_imx-image.o += -DIMXIMAGE_SSL_SUPPORT `$(PKG_CONFIG) --cflags openssl`
HOSTLDLIBS_imx-image = `$(PKG_CONFIG) --libs openssl`
endif