summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUwe Kleine-König <u.kleine-koenig@pengutronix.de>2009-09-17 10:37:03 +0200
committerUwe Kleine-König <u.kleine-koenig@pengutronix.de>2009-09-18 10:42:37 +0200
commit04ba83616f9be0ca72be7d0906ede1cf8621ab84 (patch)
treeafb7ec5d11edf571269625704c853c9be1c64890
downloaddebianrt-latest-04ba83616f9be0ca72be7d0906ede1cf8621ab84.tar.gz
debianrt-latest-04ba83616f9be0ca72be7d0906ede1cf8621ab84.tar.xz
prepare 0.0.20090917.10.0.20090917.1
Signed-off-by: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
-rwxr-xr-xbin/gencontrol58
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/copyright7
-rwxr-xr-xdebian/rules22
-rw-r--r--flavours4
-rw-r--r--latest3
7 files changed, 100 insertions, 0 deletions
diff --git a/bin/gencontrol b/bin/gencontrol
new file mode 100755
index 0000000..d3684c6
--- /dev/null
+++ b/bin/gencontrol
@@ -0,0 +1,58 @@
+#! /bin/sh
+
+uncomment() {
+ sed -e '/^#/d' -e 's/ *#.*//' "$@"
+}
+
+archs() {
+ local flavour
+
+ flavour="$1"
+
+ uncomment flavours |
+ awk -v "flavour=$flavour" -F ': *' '$1 == flavour { print $2 }'
+}
+
+flavours() {
+ uncomment flavours |
+ awk -F ': *' '{ print $1 }' |
+ sort
+}
+
+generate_control() {
+ cat << EOF
+Source: linuxrt-latest
+Section: contrib/kernel
+Priority: optional
+Maintainer: Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
+Standards-Version: 3.8.3
+Build-Depends: debhelper (>> 7)
+Origin: pengutronix.de
+Bugs: mailto:kernel@pengutronix.de
+
+EOF
+
+ for f in $(flavours); do
+ uncomment latest |
+ awk -v "archs=$(archs "$f")" -v "flavour=$f" -F ': *' '{
+ sub("^latest", "", $1);
+ print "Package: linux-image-2.6-rt" $1 "-" flavour;
+ print "Architecture: " archs;
+ print "Depends: linux-image-" $2 "-" flavour ", ${misc:Depends}"
+ sub("^-", " ", $1);
+ print "Description: Meta package depending on the latest" $1 " rt kernel"
+ print "Tag: admin::kernel, role::metapackage"
+ print "";
+ }'
+ done
+}
+
+generate_control > debian/control.tmp
+
+if test -e debian/control && cmp -s debian/control debian/control.tmp; then
+ touch debian/control
+else
+ echo "update debian/control"
+ mv debian/control.tmp debian/control
+ exit 1
+fi
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..3c92fbc
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+linuxrt-latest (0.0.20090917.1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Uwe Kleine-König <u.kleine-koenig@pengutronix.de> Wed, 17 Sep 2009 10:20:05 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7f8f011
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+7
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..36076a5
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,7 @@
+This package was created by Uwe Kleine-König <u.kleine-koenig@pengutronix.de>
+on 17 Sep 2009
+
+The whole package is copyrighted under version 2 (only) of the GPL.
+
+On Debian GNU/Linux systems, the complete text of the GNU General
+Public License Version 2 can be found in `/usr/share/common-licenses/GPL-2'
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cfd29c4
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,22 @@
+#! /usr/bin/make -f
+
+binary: binary-arch binary-indep
+binary-arch binary-indep: install
+build: build-stamp
+build-stamp: debian/control
+clean: debian/control
+install: build install-stamp
+
+build-stamp install-stamp:
+ dh ${@:-stamp=}
+ touch $@
+
+binary-arch binary-indep clean:
+ dh $@
+
+debian/control: flavours latest bin/gencontrol
+ bin/gencontrol
+ false
+
+maintainerclean:
+ rm -f debian/control
diff --git a/flavours b/flavours
new file mode 100644
index 0000000..febc8c5
--- /dev/null
+++ b/flavours
@@ -0,0 +1,4 @@
+amd64: amd64 i386
+486: i386
+686: i386
+686-bigmem: i386
diff --git a/latest b/latest
new file mode 100644
index 0000000..718ced0
--- /dev/null
+++ b/latest
@@ -0,0 +1,3 @@
+latest-osadl: 2.6.29.6-rt23-1
+latest-stable: 2.6.31-rt10-1
+latest: 2.6.31-rt10-1