summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Olbrich <m.olbrich@pengutronix.de>2010-06-03 16:19:47 +0200
committerMichael Olbrich <m.olbrich@pengutronix.de>2010-06-03 17:21:06 +0200
commit71485564ccb53196c6b6ea8c0a8ee66fbcd85fdf (patch)
tree572dca4c70228136555f466b480a46854d19d019 /configure.ac
parenta28f25b2ef74d988f58c66dab3291bdb539ef106 (diff)
downloadjson-dbus-bridge-examples-71485564ccb53196c6b6ea8c0a8ee66fbcd85fdf.tar.gz
json-dbus-bridge-examples-71485564ccb53196c6b6ea8c0a8ee66fbcd85fdf.tar.xz
[autotools] cleanup build system
Signed-off-by: Michael Olbrich <m.olbrich@pengutronix.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a9b0def..f85fab5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,16 +18,18 @@ if test "x$HAVE_PYTHON" != "xyes"; then
AC_MSG_ERROR([Python not found.])
fi
-AC_PATH_PROGS([LIGHTTPD],[lighttpd],,)
+AC_PATH_PROG([LIGHTTPD],[lighttpd],,)
if test -z "$LIGHTTPD"; then
AC_MSG_ERROR([lighttpd not found. Define LIGHTTPD=/path/to/lighttpd or make sure lighttpd is in \$PATH])
fi
+AC_ARG_VAR([LIGHTTPD], [lighttpd web server])
AC_SUBST(LIGHTTPD)
-AC_PATH_PROGS([JSON_DBUS_BRIDGE],[json-dbus-bridge],,)
+AC_PATH_PROG([JSON_DBUS_BRIDGE],[json-dbus-bridge],,)
if test -z "$JSON_DBUS_BRIDGE"; then
AC_MSG_ERROR([json-dbus-bridge not found. Set JSON_DBUS_BRIDGE=/path/to/json-dbus-bridge or make sure json-dbus-bridge is in \$PATH])
fi
+AC_ARG_VAR([JSON_DBUS_BRIDGE], [json-dbus-bridge FCGI application])
AC_SUBST(JSON_DBUS_BRIDGE)
AC_ARG_WITH([qooxdoo-sdk],AS_HELP_STRING([--with-qooxdoo-sdk=PATH], [Path to qooxdoo sdk]),
@@ -45,6 +47,8 @@ AM_INIT_AUTOMAKE([foreign no-exeext dist-bzip2])
AC_CONFIG_FILES([
Makefile
lighttpd/lighttpd.conf
+ services/Makefile
+ services/python/Makefile
web-gui/Makefile
web-gui/hello-world/Makefile
web-gui/hello-world/config.json
@@ -52,6 +56,8 @@ AC_CONFIG_FILES([
web-gui/calculator/config.json
])
AC_CONFIG_FILES([run.sh],[chmod +x run.sh])
+AC_CONFIG_FILES([web-gui/hello-world/generate.py],[chmod +x web-gui/hello-world/generate.py])
+AC_CONFIG_FILES([web-gui/calculator/generate.py],[chmod +x web-gui/calculator/generate.py])
AC_OUTPUT