summaryrefslogtreecommitdiffstats
path: root/web-gui/hello-world/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'web-gui/hello-world/Makefile.am')
-rw-r--r--web-gui/hello-world/Makefile.am24
1 files changed, 21 insertions, 3 deletions
diff --git a/web-gui/hello-world/Makefile.am b/web-gui/hello-world/Makefile.am
index af29dd7..2f3d390 100644
--- a/web-gui/hello-world/Makefile.am
+++ b/web-gui/hello-world/Makefile.am
@@ -1,10 +1,28 @@
+QOOXDOO_SOURCE = \
+ Manifest.json \
+ generate.py \
+ source/resource/hello_world/back.png \
+ source/index.html \
+ source/translation/readme.txt \
+ source/class/hello_world/Application.js \
+ source/class/hello_world/test/DemoTest.js \
+ source/class/hello_world/theme/Color.js \
+ source/class/hello_world/theme/Theme.js \
+ source/class/hello_world/theme/Decoration.js \
+ source/class/hello_world/theme/Font.js \
+ source/class/hello_world/theme/Appearance.js
+
all:
- if [ "@srcdir@" != "@builddir@" ]; then \
- cp -a "@srcdir@/"{source,generate.py,Manifest.json} "@builddir@/"; \
- fi
./generate.py build
+clean-local:
+ rm -rf build
+
+EXTRA_DIST = \
+ config.json.in \
+ $(QOOXDOO_SOURCE)
+
MAINTAINERCLEANFILES = \
Makefile.in