summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnrico Jorns <ejo@pengutronix.de>2016-07-08 14:37:59 +0200
committerEnrico Jorns <ejo@pengutronix.de>2016-08-15 16:05:28 +0200
commit87e93c1e2a542044d01be148832b1ba977c1795d (patch)
tree0d496931b7920cbcfd48a55ec117e857e23eb715
parent92e6ab6847b37409ff767be8bac4bf69812539cd (diff)
downloadmeta-ptx-krogoth.tar.gz
meta-ptx-krogoth.tar.xz
rauc-native: move native deploy task to extra recipekrogoth
This fixes sstate issues when trying to accelerate do_deploy task from sstate for non-native packages. These did not install anything to deploy dir which made sstate_installpkg fail with: | 0317: for state in ss['dirs']: | 0318: prepdir(state[1]) | *** 0319: os.rename(sstateinst + state[0], state[1]) | 0320: sstate_install(ss, d) | 0321: | 0322: for plain in ss['plaindirs']: | 0323: workdir = d.getVar('WORKDIR', True) | Exception: OSError: [Errno 2] No such file or directory By adding the deploy task only for the native recipe (where it is used) this issue is fixed. This also changes install location from ${DEPLOY_DIR_TOOLS} to ${DEPLOYDIR} which is the one used as sstate-inputdirs. Signed-off-by: Enrico Jorns <ejo@pengutronix.de>
-rw-r--r--recipes-core/rauc/rauc-native_git.bb13
-rw-r--r--recipes-core/rauc/rauc.inc17
2 files changed, 14 insertions, 16 deletions
diff --git a/recipes-core/rauc/rauc-native_git.bb b/recipes-core/rauc/rauc-native_git.bb
new file mode 100644
index 0000000..661226a
--- /dev/null
+++ b/recipes-core/rauc/rauc-native_git.bb
@@ -0,0 +1,13 @@
+require rauc_git.bb
+
+inherit native deploy
+
+do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
+
+do_deploy() {
+ install -d ${DEPLOYDIR}
+ install -m 0755 ${B}/rauc ${DEPLOYDIR}/rauc-${PV}
+ ln -sf rauc-${PV} ${DEPLOYDIR}/rauc
+}
+
+addtask deploy before do_package after do_install
diff --git a/recipes-core/rauc/rauc.inc b/recipes-core/rauc/rauc.inc
index fda630f..51e08de 100644
--- a/recipes-core/rauc/rauc.inc
+++ b/recipes-core/rauc/rauc.inc
@@ -65,24 +65,9 @@ do_install_append_class-target () {
}
-inherit deploy
-do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
-
-do_deploy() {
-}
-
-do_deploy_append_class-native() {
- install -d ${DEPLOY_DIR_TOOLS}
- install -m 0755 ${B}/rauc ${DEPLOY_DIR_TOOLS}/rauc-${PV}
- rm -f ${DEPLOY_DIR_TOOLS}/rauc
- ln -sf ./rauc-${PV} ${DEPLOY_DIR_TOOLS}/rauc
-}
-
-addtask deploy before do_package after do_install
-
SYSTEMD_PACKAGES = "${PN}-service ${PN}-mark-good"
SYSTEMD_SERVICE_${PN}-service = "rauc.service"
SYSTEMD_SERVICE_${PN}-mark-good = "rauc-mark-good.service"
SYSTEMD_AUTO_ENABLE_${PN} = "enable"
-BBCLASSEXTEND = "native nativesdk"
+BBCLASSEXTEND = "nativesdk"