summaryrefslogtreecommitdiffstats
path: root/recipes-core
diff options
context:
space:
mode:
authorEnrico Jorns <ejo@pengutronix.de>2016-08-22 22:22:56 +0200
committerEnrico Jorns <ejo@pengutronix.de>2016-11-10 17:00:29 +0100
commit6c5dfab5a7804e41aacef59822a48d5e3b33f206 (patch)
tree3e5237ee524e0e77832eda68fe8b374c27f01138 /recipes-core
parent42074266e10408daa078df2d2778e116998de46d (diff)
downloadmeta-ptx-6c5dfab5a7804e41aacef59822a48d5e3b33f206.tar.gz
meta-ptx-6c5dfab5a7804e41aacef59822a48d5e3b33f206.tar.xz
dt-utils: update to 2016.08.0 and switch to using tarball release
Note that this also splits the recipe in a version-specific bb file and a version-agnostic include file. Signed-off-by: Enrico Jorns <ejo@pengutronix.de>
Diffstat (limited to 'recipes-core')
-rw-r--r--recipes-core/dt-utils/dt-utils.inc (renamed from recipes-core/dt-utils/dt-utils.bb)6
-rw-r--r--recipes-core/dt-utils/dt-utils_2016.08.0.bb4
-rw-r--r--recipes-core/dt-utils/files/0001-remove-init-option-use-default-if-load-failed.patch90
3 files changed, 5 insertions, 95 deletions
diff --git a/recipes-core/dt-utils/dt-utils.bb b/recipes-core/dt-utils/dt-utils.inc
index 994121e..9595e95 100644
--- a/recipes-core/dt-utils/dt-utils.bb
+++ b/recipes-core/dt-utils/dt-utils.inc
@@ -4,13 +4,9 @@ SECTION = "base"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=9ac2e7cff1ddaf48b6eab6028f23ef88"
DEPENDS = "udev"
-SRCREV = "b1a52928e7bf4126bbe014ee434bd91c4f804bba"
PR = "r0"
-SRC_URI = "git://git.pengutronix.de/git/tools/dt-utils.git \
- file://0001-remove-init-option-use-default-if-load-failed.patch "
-
-S = "${WORKDIR}/git"
+SRC_URI = "http://www.pengutronix.de/software/dt-utils/download/${PN}-${PV}.tar.xz"
inherit autotools pkgconfig gettext
diff --git a/recipes-core/dt-utils/dt-utils_2016.08.0.bb b/recipes-core/dt-utils/dt-utils_2016.08.0.bb
new file mode 100644
index 0000000..bad2cda
--- /dev/null
+++ b/recipes-core/dt-utils/dt-utils_2016.08.0.bb
@@ -0,0 +1,4 @@
+require dt-utils.inc
+
+SRC_URI[md5sum] = "b10ec651cfb241544a2eb23b5a9f156d"
+SRC_URI[sha256sum] = "6fa29f2b38251847376bb78c4a2b6cb126f713a1953c189358e98076cea2dbef"
diff --git a/recipes-core/dt-utils/files/0001-remove-init-option-use-default-if-load-failed.patch b/recipes-core/dt-utils/files/0001-remove-init-option-use-default-if-load-failed.patch
deleted file mode 100644
index f860af7..0000000
--- a/recipes-core/dt-utils/files/0001-remove-init-option-use-default-if-load-failed.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-From a2eb91de7d3b7a926f18fec3dc97ded15a445b0a Mon Sep 17 00:00:00 2001
-From: Enrico Jorns <ejo@pengutronix.de>
-Date: Wed, 24 Jun 2015 15:44:19 +0200
-Subject: [PATCH] remove init option: use default if load failed
-
-This change is done do match the behavior with barebox.
-If loading the environment from storage failed, the default values will
-be used. Thus an explicit initalization of the state is not required
-anymore.
-
-Signed-off-by: Enrico Jorns <ejo@pengutronix.de>
----
- src/barebox-state.c | 19 ++++---------------
- 1 file changed, 4 insertions(+), 15 deletions(-)
-
-diff --git a/src/barebox-state.c b/src/barebox-state.c
-index 02e085b..1e0c7f1 100644
---- a/src/barebox-state.c
-+++ b/src/barebox-state.c
-@@ -1996,7 +1996,6 @@ static struct option long_options[] = {
- {"name", required_argument, 0, 'n' },
- {"dump", no_argument, 0, 'd' },
- {"dump-shell", no_argument, 0, OPT_DUMP_SHELL },
-- {"init", no_argument, 0, 'i' },
- {"verbose", no_argument, 0, 'v' },
- {"help", no_argument, 0, 'h' },
- };
-@@ -2011,7 +2010,6 @@ static void usage(char *name)
- "-n, --name <name> specify the state to use (default=\"state\")\n"
- "-d, --dump dump the state\n"
- "--dump-shell dump the state suitable for shell sourcing\n"
--"-i, --init initialize the state (do not load from storage)\n"
- "-v, --verbose increase verbosity\n"
- "--help this help\n",
- name);
-@@ -2031,7 +2029,7 @@ int main(int argc, char *argv[])
- struct state *state;
- struct state_variable *v;
- int ret, c, option_index;
-- int do_dump = 0, do_dump_shell = 0, do_initialize = 0;
-+ int do_dump = 0, do_dump_shell = 0;
- struct state_set_get *sg;
- struct list_head sg_list;
- char *statename = "/state";
-@@ -2039,7 +2037,7 @@ int main(int argc, char *argv[])
- INIT_LIST_HEAD(&sg_list);
-
- while (1) {
-- c = getopt_long(argc, argv, "hg:s:divn:", long_options, &option_index);
-+ c = getopt_long(argc, argv, "hg:s:dvn:", long_options, &option_index);
- if (c < 0)
- break;
- switch (c) {
-@@ -2061,9 +2059,6 @@ int main(int argc, char *argv[])
- case 'd':
- do_dump = 1;
- break;
-- case 'i':
-- do_initialize = 1;
-- break;
- case OPT_DUMP_SHELL:
- do_dump_shell = 1;
- break;
-@@ -2079,13 +2074,7 @@ int main(int argc, char *argv[])
- if (IS_ERR(state))
- exit(1);
-
-- if (!do_initialize) {
-- ret = state_load(state);
-- if (ret) {
-- fprintf(stderr, "Cannot load state: %s\n", strerror(-ret));
-- exit(1);
-- }
-- }
-+ state_load(state);
-
- if (do_dump) {
- state_for_each_var(state, v) {
-@@ -2146,7 +2135,7 @@ int main(int argc, char *argv[])
- }
- }
-
-- if (do_initialize || state->dirty) {
-+ if (state->dirty) {
- ret = state_save(state);
- if (ret) {
- fprintf(stderr, "Failed to save state: %s\n", strerror(-ret));
---
-2.1.4
-